Highlighted
Absent Member.
Absent Member.
836 views

Has anyone solved issues with inconsistent SMTP connections to Exchange?

We are running HPSM 9.32.  We are seeing a 25% rate of "Unable to connect" messages.

 

After a series of unable to connect and java dumps that look like the following, we finally see this:

 

  3840(  1164) 02/26/2015 09:41:25 java.lang.Thread.run(Unknown Source)
  3840(  1164) 02/26/2015 09:41:25 JRTE I Unable to connect to mail server, sleep 5 seconds and retry.
  3840(   528) 02/26/2015 09:41:25 com.sun.mail.smtp.SMTPTransport.issueSendCommand(SMTPTransport.java:1388)
  3840(   528) 02/26/2015 09:41:25 com.sun.mail.smtp.SMTPTransport.mailFrom(SMTPTransport.java:959)
  3840(   528) 02/26/2015 09:41:25 com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:583)
  3840(   528) 02/26/2015 09:41:25 com.hp.ov.sm.server.utility.htmlemail.impl.MailSessionImpl.sendInner(MailSessionImpl.java:552)
  3840(   528) 02/26/2015 09:41:25 com.hp.ov.sm.server.utility.htmlemail.impl.MailSessionImpl.sendMail(MailSessionImpl.java:510)
  3840(   528) 02/26/2015 09:41:25 com.hp.ov.sm.server.utility.htmlemail.impl.MailSessionImpl.access$000(MailSessionImpl.java:47)
  3840(   528) 02/26/2015 09:41:25 com.hp.ov.sm.server.utility.htmlemail.impl.MailSessionImpl$EmailTask.process(MailSessionImpl.java:688)
  3840(   528) 02/26/2015 09:41:25 com.hp.ov.sm.server.utility.htmlemail.impl.MailSessionImpl$MailThread.handleTask(MailSessionImpl.java:835)
  3840(   528) 02/26/2015 09:41:25 com.hp.ov.sm.server.utility.htmlemail.impl.MailSessionImpl$MailThread.process(MailSessionImpl.java:824)
  3840(   528) 02/26/2015 09:41:25 com.hp.ov.sm.server.utility.htmlemail.impl.MailSessionImpl$MailThread.run(MailSessionImpl.java:764)
  3840(   528) 02/26/2015 09:41:25 java.lang.Thread.run(Unknown Source)
  3840(   528) 02/26/2015 09:41:25 JRTE I Unable to send mail, retry one more time.
  3840(   528) 02/26/2015 09:41:25 JRTE I Connect to mail server sucessfully. [mymail-server.host.domain]:25

The log then shows 9 more of these Connect to mail server sucessfully messages.

Then there are 10 of these messages:

  3840(  4660) 02/26/2015 09:41:30 JRTE I MailThread completed task in 5304 milliseconds.

Then 4 of these messages

  1928(  5616) 02/26/2015 09:43:37  RAD I ERROR;HTML Templates;getTemplate;Template cas.cm3r.notify.fmt could not be found.

and  one of these:

  3052(  4976) 02/26/2015 09:44:02  RTE I killInactiveSessions: elapsed time 0 milliseconds, warning 2, setTerminateStatus 0.

 

 

After all of that, there are a number of Email has been sent to user@host.domain type messages.

Occasionally after the unable to connect messages we also see

  3840(   528) 02/26/2015 09:41:25 JRTE I Unable to send mail, retry one more time.

 

I talked to the exchange server and he indicated that this sounded to him like some sort of issue.

 

Are there known issues with HPSM 9.32 running on Windows having problems sending mail through SMTP to exchange?

 

Thank you

Tags (1)
4 Replies
Highlighted
Contributor.. Contributor..
Contributor..

Re: Has anyone solved issues with inconsistent SMTP connections to Exchange?

Hi,

It is sad nobody else is having this issue, because we are.

So to anyone, this topic is still in need for an answer, or a lead to a direction, if you have one!

Thanks!

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: Has anyone solved issues with inconsistent SMTP connections to Exchange?

Hi,

I have seen this issue and resolved It,

This issue is primarily due to multiple exchange server at your organisation  , it could happen due to multiple reason

The exchange server IP address you are using may be relay server, request are often routed to other exchange server; where your request is getting failed due to white-listing of your server or Messaging type SM using is supported by some exchange server and some does not.

you can also check by running continuous ping test from SM to Exchange server to check latency issue.

Primary, I would recommend you to work with your exchange team on resolving this issue, review logs on routing request.

0 Likes
Highlighted
Contributor.. Contributor..
Contributor..

Re: Has anyone solved issues with inconsistent SMTP connections to Exchange?

Thank you Madddy,

We will have a chat with the Exchange team regarding relays and their logs.

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: Has anyone solved issues with inconsistent SMTP connections to Exchange?

Hi jay,

Keep us posted on the outcome of your discussion with Exchange Team.

if my Post has helped you, Would really appreciate if you could appreciate efforts/time by giving Likes 🙂

Regards,

Madhan

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.