Highlighted
bg-hpsm Absent Member.
Absent Member.
395 views

Heartbeat timeout in HPSM

Hello folks, 

 

I have a standalone (thik) desktop client system which is utilized to run dashboards on a large display. For some reason the client gets disconnected often from the server, find below the error logs. I have tried connecting the client directly to a server port rather the loadbalancer port, but still the same issue. Sometimes the user logged on to the system for close to a day/two and sometimes for only a couple of hours. 

 

   2936(  6996) 01/22/2015 10:53:27 JRTE I My client (F79A9025487A54D47F1E5E0885613EF5) has died, no heartbeat

  2936(  2656) 01/22/2015 10:53:27 JRTE I Termination signal: 0

  2936(  2656) 01/22/2015 10:53:27  RTE I -Memory : S(3500920) O(1173700) MAX(4982236) - MALLOC's Total(2283537)

  2936(  2656) 01/22/2015 10:53:27  RTE I Thread termination in progress

  2936(  2656) 01/22/2015 10:53:27  RTE I User  DASHBOARD1 has logged out and freed a Floating license ( 79 out of a maximum 251 )

  2936(  2656) 01/22/2015 10:53:27  RTE I sql total 70.010  call#:13612 -->sqociDisconnect:OCISessionEnd

  2936(  2656) 01/22/2015 10:53:27  RTE I sql total 70.010  call#:13613 -->sqociDisconnect:OCIServerDetach

  2936(  2656) 01/22/2015 10:53:27  RTE I Thread termination cleanup complete

 

My understanding is that this above disconnection is because of the session timeout configured in HPSM which is 3 minutes (ini file). I also know that the default timeout session configured in HPSM is 30 minutes. Since we have reduced it to 3 minutes so that the user connections gets killed when the client system is not active and improve the performance / reduce the usage for an inactive session. 

 

Is there any ways we could have just this user excluded from the heartbeat termination?  We were thinking to create a new servlet and specifically mention the session timeout parameter to an hour or so and allow the dashboard user to connect to the servlet, but wasting 2 GB of memory for a servlet on this single user doesn’t seem fruitful.

 

Kindly provide if there is any alternative solution. 

 

Btw, the user is already under the inactive user list. I am on 9.31.XX both the server as well the thick client. 

 

 

0 Likes
9 Replies
Absent Member.. Tong Yan Absent Member..
Absent Member..

Re: Heartbeat timeout in HPSM

Hi bg-hpsm,

 

You can set it in two places:

1. operator record: Allowed Inactive Time

2. System Administration > Ongoing Maintenance > System  > Start Inactivity Timer: Minutes of termination, Do not terminate these users

 

Please note, inactivity timer works differently from sm app 9.30: Not use background process.

 

You can refer to sm help server for detail: System Administration > System Security > Inactivity timer

Cheers 🙂
Yan Tong (Serene), HP Software Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution; and give kudo if you like it 🙂
0 Likes
bg-hpsm Absent Member.
Absent Member.

Re: Heartbeat timeout in HPSM

Hello Yan,  Thanks for your response. 

 

No... This is not related to inactivity timer issue. I have already mentioned in my post that the user is set under "DO Not terminate these users".

Session timeout and heartbeat timeout settings are totally different from the inactivity setup. 

 

Could you check and let me know if there is anyway to make the user never log out the system even if the heartbeat fails / session timeout exceeds. 

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Heartbeat timeout in HPSM

Hello,

 

There is no way to allow a user to stay logged on to SM if the heartbeatinterval fails and/or if the session timeout is exceeded. This behaviour is completely against the design of the heartbeat and session timeout functionality.

 

Regards,

0 Likes
bg-hpsm Absent Member.
Absent Member.

Re: Heartbeat timeout in HPSM

Hi dmitch 

 

Thanks and I understand your point on this heartbeat design. But if the requirement is to exclude any user from the session timeout isnt that possible?

 

Btw, could you answer this question please..

 


We were thinking to create a new servlet and specifically mention the session timeout parameter to an hour or so and allow the dashboard user to connect to the servlet.

 

Would  you consider the above option as a possible solution by creating a new servlet for this user alone with a different session timeout (300 minutes with a heartbeat every 60 seconds)and keeping the system wide timeout as 3 minutes?

Ex: sm -httpPort:13099 -httpsPort:13542 -sslConnector:0 -JVMOption0:-Xms512m -JVMOption1:-Xmx1024m -JVMOption2:-XX:+HeapDumpOnOutOfMemoryError -log:"D:\Service Manager 9.30\Server\logs\sm13099.log" -heartbeatinterval:60 -sessiontimeout:300

Tags (4)
0 Likes
bg-hpsm Absent Member.
Absent Member.

Re: Heartbeat timeout in HPSM

HP Team,

 

Any suggestion on the above servelet parameter please?

0 Likes
Absent Member.. roberto_rb Absent Member..
Absent Member..

Re: Heartbeat timeout in HPSM

Hi,

 

Just as a comment, starting a new servlet doesn't mean that it will consume 2GB inmediately, this depends on what activities will be done on that servlet.

 

About your question, I would say it is fine if you start this servlet from the OS command line (or the sm.cfg if needed) so that this user can connect to it and have a higher sessiontimeout and be able to perform the needed tasks.

 

You could give it a try and confirm the results, it should stay longer than the original 30 minutes that were set by default.

 

Regards,

Roberto

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Heartbeat timeout in HPSM

In addition to Roberto's comments above, I would also remove the following options -JVMOption0:-Xms512m -JVMOption1:-Xmx1024m unless you have been specifically advised to add them.

 

Thanks,

0 Likes
Absent Member.. Tong Yan Absent Member..
Absent Member..

Re: Heartbeat timeout in HPSM

Hi bg-hpsm,

 

Yes, this is a feasible way to achieve the requirement. I also thought of this later last night, and was going to suggest this.

 

If you use sm loadbalancer, you need to use "-debugnode:1" for this servlet.

 

And make sure you have enough cpu and memory to support this additional servlet. "-JVMOption1:-Xmx1024m" might be a little bigger than normally setting. It's not the bigger the better. You need to tune this parameter.

Cheers 🙂
Yan Tong (Serene), HP Software Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution; and give kudo if you like it 🙂
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Heartbeat timeout in HPSM

Does your dashboard actually auto-refresh and provide the latest info ? I thought auto refresh was disabled in some version before sm 9.31. The heartbeat track communication between the client and the server. If the client pulls data occassionally from the db, there should be heartbearts. I'm just wondering whether SM existing dashboard functionality actually serve your need or whether you need a different solution.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.