Highlighted
Outstanding Contributor.
Outstanding Contributor.
156 views

How to enable continuous sync of all AD Contacts in SM 9.40 using LDAP and Cit 9.60

Hi,

 

 

SM 9.40 Windows Environment and Microsoft AD Services

 

After carrying out the necessary LDAP configuration, we are able to see that All AD users are able to login into the SM as ESS Users for submitting a request.

 

however, they are not able to get fields of "service recipient", "primary contact" , "email id" filled automatically with their own name. Nor its allowing us to manually fill any user name,

 

if we tried manually to add a name and proceed, it says "xxx xxx is not a valid Contact Name in the contacts file (display,get.action)"

 

With above scenario, our HELPDESK team is also not able to open the new interactions as user data is not available in the system.

 

Helpdesk is held up , please help...

 

Thanks and Regards

Hemant Vaswani

0 Likes
2 Replies
Highlighted
Outstanding Contributor.
Outstanding Contributor.

hi,

 

i was able to figure out the option by modifying the following paramateris in the sm.ini and restarted the sm service.

 

ldapauthenticateonly:0

 

however, after doing the above change, the i was just able to test one or two cases, snd suddenly got HP's hourglass(square and moving boxes) and then got logged out of sm with message in red in login screen = servcie unavailable.

 

on diagnosis, i found that sm.log had grown and inflated to the size of 6+GB and growing.

i stopped the service and added the following parameter in sm.ini

 

ldapdisconnect:1

 

still same scenario, restarted the sm service, again the sm.log went on inflating and hence stopped the service.

 

kindly suggest for the way forward,

 

Thanks and Regards

Hemant Vaswani

 

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Hernant,

 

I hope you are doing fine.

 

The parameter "ldapauthenticateonly" requires the HP Service Manager server to use LDAP for login authentication only. If you want to disable it just comment it.

 

Parameter "ldapdisconnect" specifies when the SM server disconnects from the LDAP server. If you put ldapdisconnect:0, it will disconnect after client log out. Instead if you put a 1, it will disconnect after every transaction.

 

I recommend you to get a trace of the behavior with the parameter ldapstats:1 enabled in the Initialization file (sm.ini). Then please submit a SM Support Ticket and attach the trace  into it.

 

Best regards,

 

Andres Valverde Jimenez

HP Software Support

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

Also, please assign a Kudo to the post if you find it is helpful .

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.