Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
982 views

How to skip indexing libraries that are not used

Jump to solution

Hello,


We are using version 9.40.  In our environment we only use the Knowledge Library for Knowledge searching.  We do not use the Problem, Incident, Interaction, or Known error libraries.

 

In the knowledgebase configuration I set the reindex time to '0', but the sm.log still has the following entry.  I left out the other four but they are similar.

 

  4808(  3188) 07/01/2015 08:33:53 Core: Interaction_Library is down or does not exist
  4808(  3188) 07/01/2015 08:33:53 [Ljava.lang.StackTraceElement;@10ae357
java.lang.NullPointerException
    at com.hp.ov.sm.server.plugins.knowledgemanagement.solr.KMSolrSearch.getIndexStatistics(KMSolrSearch.java:927)
    at com.hp.ov.sm.server.utility.GenericServerThread.symanContinue(Native Method)
    at com.hp.ov.sm.server.utility.GenericServerThread.run(GenericServerThread.java:58)

 

How can exclude the Interaction_Library from being attempted to be indexed?  I have already disabled the trigger to add to the kmknowledgebase updates table, so there isn't going to be any entries to be indexed in the future.

 

Thanks for the help.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Established Member..
Established Member..

Hi guys,

Knowledge Management -> Configuration -> Knowledgebases

hit search and remove the "Search Server Name" from Knowledgebases you don't want associated with your searcher. Click save, move to the next one.

You'll notice only the active knowledgebases will have information in the Status window.

 

Cheers.

 

View solution in original post

0 Likes
7 Replies
Highlighted
Absent Member.
Absent Member.

You can try to set the query to 'false' in each unwanted library.

____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
0 Likes
Highlighted
Contributor.
Contributor.

Could you tell how to set 'false'? (I mean: where to modify which record)

thanks in advance!

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

System Navigator > Knowledge Management > Configuration > Knowledgebases > <library>

1. Set Refresh Interval to 0
2. Set Table Query to: false

Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
Setting the table query to false doesn't appear to prevent the engine from attempting to run against the specific library. In fact doing so (and following the SM recommendation to perform a full reindex) causes a negative side effect of displaying that library on the Search Knowledgebase page.

Are there any other ideas to accomplish this?
0 Likes
Highlighted
Established Member..
Established Member..

I think after you table query to false or empty , Don't click the "Full Reindex" button , this KB should show "Offline" so indexer can skip processing it. 

0 Likes
Highlighted
Established Member..
Established Member..

Hi guys,

Knowledge Management -> Configuration -> Knowledgebases

hit search and remove the "Search Server Name" from Knowledgebases you don't want associated with your searcher. Click save, move to the next one.

You'll notice only the active knowledgebases will have information in the Status window.

 

Cheers.

 

View solution in original post

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
That did it Lukus.
Thanks for the tip-
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.