Absent Member.. sm-turbo Absent Member..
Absent Member..
272 views

Installing new Service Manager 7.11 on new hardware arch. need SM web tier installation help

Jump to solution

Hi,

I have been using SM for a while, just got into some heavy duty projects so in need of some upper level help. So far I have setup SM 7.11.532 on our LB and 2 APP servers, using the client I am able to log in and use SM as normal.

We are on Windows Server 2008 and have one Web App server. On that I follow the directions as best I could, searching though forums and using HPs install guide.

1. Installed jdk-1_5_0_22-windows-i586-p

    - created JAVA_HOME variable

2. Extracted Tomcat Apache 5.5.35 to a folder.

3. Placed webtier-7.11.war in the webapps/ folder (not sure what I have to do with the other file? webtier-ear-7.11.ear )

4. Started tomcat, edited the web.xml file with the defauts in HPs installing guide and shutdown and restarted tomcat.

I am able to go to http://localhost:8080/ and was able to get into the Manager link and then to http://localhost:8080/webtier-7.11/index.do

I get this error:

javax.xml.soap.SOAPException: Message send failed - connection to host http://localhost:13080/SM/ui refused. Your server session may have been terminated or timed out. You may need to go to the login page and log in once again.

Researching this topic I found out that I am not connection to my SM app server, which field would I use and how can I connect to the app server. All of the above steps is all I have done on our web server. The port we use to connect to SM is 13080...among others but thats the main one.

thanks in advance!









0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

Re: Installing new Service Manager 7.11 on new hardware arch. need SM web tier installation help

Jump to solution

Hi,

 

Please check if your web.xml has the securelogin parameter. If so, let's make it false and restart the Apache/Tomcat.

 

Regards,

 

Luis

If you feel this was helpful please click the KUDOS! thumb below!
0 Likes
4 Replies
Micro Focus Expert
Micro Focus Expert

Re: Installing new Service Manager 7.11 on new hardware arch. need SM web tier installation help

Jump to solution

Hi,

 

Please check if your web.xml has the securelogin parameter. If so, let's make it false and restart the Apache/Tomcat.

 

Regards,

 

Luis

If you feel this was helpful please click the KUDOS! thumb below!
0 Likes
Absent Member.. sm-turbo Absent Member..
Absent Member..

Re: Installing new Service Manager 7.11 on new hardware arch. need SM web tier installation help

Jump to solution

That fixed it! I also had to change serverhost to what was in the desktop client, I kept it as localhost, I know noob mistake on my part.

 

Thanks, I'm up and running on my web app.



What link would I use on my laptop to access this SM Web instance, how can I access/change that address?

Thanks! 

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Installing new Service Manager 7.11 on new hardware arch. need SM web tier installation help

Jump to solution

Him

 

You should use the apache/tomcat link plus the name of the deployment. Example:

 

http://myApacheTomcatserver:8080/SM930/index.do

 

Regards,

 

Luis

If you feel this was helpful please click the KUDOS! thumb below!
0 Likes
Highlighted
Absent Member.. sm-turbo Absent Member..
Absent Member..

Re: Installing new Service Manager 7.11 on new hardware arch. need SM web tier installation help

Jump to solution

thanks for the reply, I got that part. My question was more twoards how do I change the link name so that instead of what you wrote it says smweb.companyName.com ? 

Also when I use any browser I find that the login name and password fields are stretched to the right end of the browser, can that be changed?

Using IE8 and also compatability mode I get there error message on the bottom left hand of the browser:

I get this everytime I login, does not show up on anyother page only after sign-on:

 

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET4.0E)
Timestamp: Wed, 29 Aug 2012 19:16:48 UTC


Message: Object doesn't support this property or method
detail.do
Line: 153
Char: 34
Code: 0

 

I got this error a few time also, not showing up after I cleared cache/history.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET4.0E)
Timestamp: Wed, 29 Aug 2012 19:11:16 UTC

 

Message: Invalid argument.
cwc.initfw.min.js
Line: 1
Char: 1834
Code: 0

 


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.