Highlighted
HenrikBrattlie Super Contributor.
Super Contributor.
993 views

Issue with Vote, Comment & Attachment in Knowledge Articles

These issues are for Service Portal, and not in the Service Manager client.

Attachments added to Knowledge Articles are shown besides the KM article, but the link does not work:
km-attach-link-broken.png

Note that the link points to <base>/api/km/doc/.., but the actual URL seems to be <base>/sx-client/support/knowledge.. Can this be altered in the application? Is it the case of a link that hasn't been updated in the SM application, but only in SMSP/Propel?
A known work around is to add a link to attatchment in the knowledge article itself.
KM-attach-link-workaround.png

The links to vote (up and down) and the link to comment does not work either:
KM-Vote-Comment-Broken.png

The images link to: scactivelink://kmfeedback:like, scactivelink://kmfeedback:comments and scactivelink://kmfeedback:dislike.
These links do not do anything. How can scactivelink be set?

Service Portal v.9.52. Service Manager 9.50.0025.

Please advise!

 

0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

Re: Issue with Vote, Comment & Attachment in Knowledge A

I believe there is a hotfix/patch for the voting buttons and comments. I would raise a support ticket for this

Micro Focus Expert
Micro Focus Expert

Re: Issue with Vote, Comment & Attachment in Knowledge A

Log a case with support and mention QCCR1E144274. There's a hotfix for this as mentioned by Sean.

0 Likes
Carlos_V_SM Acclaimed Contributor.
Acclaimed Contributor.

Re: Issue with Vote, Comment & Attachment in Knowledge A

Hi ,

hope you are doing fine.

I would like to know if you still require assistance or if your question was resolved. If so, could you please mark it as a correct answer so that other members can benefit from this answer and close this question. If it didn’t resolve then please let me know so that we can address your question again.

Carlos Villalobos R
Customer Support Engineer
If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
Carlos_V_SM Acclaimed Contributor.
Acclaimed Contributor.

Re: Issue with Vote, Comment & Attachment in Knowledge A

Hi ,
hope you are doing fine.
I would like to know if you still require assistance or if your question was resolved. If so, could you please mark it as a correct answer so that other members can benefit from this answer and close this question.


best regards.

Carlos Villalobos R
Customer Support Engineer
If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
HenrikBrattlie Super Contributor.
Super Contributor.

Re: Issue with Vote, Comment & Attachment in Knowledge A

According to support the hotfix should work, but we have not been able to use it. It crashes our portal. The issue has not been resolved.

If anyone knows how to manually fix this, without the hotfix, please let me know.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.