Commodore Commodore
Commodore
481 views

Issues integrating SM with OMi

Hello,

We are working on integrating SM 9.64 with OMi 2020.05 using the integration steps mentioned in https://docs.microfocus.com/itom/Service_Manager:9.64/OMIAddOMIIntegration 

The document is not clear for the parameter username. Should it be the SM integration user or the OMi integration user?.

We have tried with both SM and OMi integration user, but when we try to verify the connection, we get the error 
Error calling method: doHttpRequest in class: com/hp/ov/sm/server/utility/HttpClient Exception (java.net.ConnectException: Connection refused (Connection refused))

Please advise.

Regards,
Matilda
0 Likes
8 Replies
Micro Focus Expert
Micro Focus Expert

Hi Matilda,

"username" is an operator defined in ServiceManager. 

The operator needs to have a password, you cannot use for example "falcon" without password for the integration.

Best regards,

Heike

Thank you for using the MicroFocus ServiceManager Support and News Forum. If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Commodore Commodore
Commodore

@HeikeUlshoefer ,

Thank you for your response.

The error still appears with SM user. The integration user is a clone of falcon and has a password.

Any idea what could be causing the issue?

Regards,
Matilda
0 Likes
Micro Focus Expert
Micro Focus Expert

Local and/or network firewall?

0 Likes
Commodore Commodore
Commodore

Firewall has been disabled.

However, the documentation is a little confusing. In the SM documents it mentions server:port for omi.server.url. However, if we refer to OMi document, it says only servername

https://docs.microfocus.com/OMi/2020.05/OBM_Integrations_Guide/Content/Integrations.htm 

OMi.PNG

Regards,
Matilda
0 Likes
Commodore Commodore
Commodore

@HeikeUlshoefer ,

According to the link https://docs.microfocus.com/itom/Service_Manager:9.64/OMICreateUserAccountsForOMIIntegration it says it should be created in OMi.

"Create a user account with system administration privileges on each OMi server. For details, see the OMi online help.

This is the user account that Service Manager uses to access the OMi server and to synchronize incident changes back.

Later, when configuring the Service Manager server as a connected server in OMi, you must specify this user's login name as the Name of the Service Manager server on the General tab, and specify this user's password as the Password on the Incoming Connection tab".

Unfortunately, we are still getting the error with both SM and OMi user.

And if we enable the SMIS instance without verifying, an Incident is being logged in SM with the SM integration user.

Regards,
Matilda
Commodore Commodore
Commodore

According to the link https://docs.microfocus.com/itom/Service_Manager:9.64/OMICreateUserAccountsForOMIIntegration it says it should be created in OMi.

"Create a user account with system administration privileges on each OMi server. For details, see the OMi online help.

This is the user account that Service Manager uses to access the OMi server and to synchronize incident changes back.

Later, when configuring the Service Manager server as a connected server in OMi, you must specify this user's login name as the Name of the Service Manager server on the General tab, and specify this user's password as the Password on the Incoming Connection tab".

Unfortunately, we are still getting the error with both SM and OMi user.

And if we enable the SMIS instance without verifying, an Incident is being logged in SM with the SM integration user.

Regards,
Matilda
Regards,
Matilda
0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

@Matilda 

You need to use SM Admin user or SM user with proper rights to create and update Incidents in SM.

Verify the user has RESTFul API capability word in the operator record and confirm you are using the HTTP port of SM and secure HTTP is uncheck while configuring the connected Server at OMi side.

-Thank you.

0 Likes
Commodore Commodore
Commodore

@HSSachin ,

Thank you for your response.

The documentation is in fact confusing. If you refer to the link I have posted above, it says

"Create a user account with system administration privileges on each OMi server. For details, see the OMi online help.

This is the user account that Service Manager uses to access the OMi server and to synchronize incident changes back.

Later, when configuring the Service Manager server as a connected server in OMi, you must specify this user's login name as the Name of the Service Manager server on the General tab, and specify this user's password as the Password on the Incoming Connection tab. See Configure the Service Manager server as a connected server in OMi.

Also, you need to specify the same user account when adding an SM-OMi integration instance for each OMi server (the username and Password parameters). See Add an integration instance for each OMi server."

The connection is added in SMIS to send the update from SM in OMi, so we need to use the OMi user with the appropriate rights.
As of now, we still see the http status error when we update records but the sync to OMi is working.

Regards,
Matilda
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.