Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
230 views

LWSSO between different domains (SMA-SM Portal to SM)

We have SMA-Service Manager installed on windows servers and SMA-SM installed on Linux.

I have now reached the part of the configuration where I have to set up LWSSO between SMA-SM and Service Manager:

"Now you can configure LS-SSO in the Service Manager server. The Service Manager server must use the same domain and encryption key (initString) as SMA."

The problem is that our company have the Linux servers in one domain and the windows servers in another domain.

Has anyone had this problem? Any advice is much appreciated.

 

 

0 Likes
4 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: LWSSO between different domains (SMA-SM Portal to SM)

I have the same problem.

Any news?

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: LWSSO between different domains (SMA-SM Portal to SM)

Hi Roberto

It is working for us now. This is how I configured it:

We have the SM application server in one domain (windowsserver1.domainXXX.shb.biz) and the Linux server in another domain (linuxserver1.domainYYY.shb.biz).

 

1.) In SMA-SM SP I configured it in Configuration ==> Security ==> Lightweight SSO configuration. As domain I set the windows domain, i.e. the domain where the windows SM applications server is (not the local domain).

2.) Log on the windows SM application server.
Edit the \RUN\lwssofmconf.xml file to match the values in the Portal configuration
The initString in this file should be the same value as the Encryption key in SMA-SM Portal. The domain must also be the same

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: LWSSO between different domains (SMA-SM Portal to SM)

Great!!!
Thanks.
Last doubt.
What about if behind SM windows machines they have a F5 balancer with domain equal to SP domain? I should ignore it and make your configuration?
Thanls again
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: LWSSO between different domains (SMA-SM Portal to SM)

Hi Roberto

We dont have the same setup as you do with an F5 load balancer, so I cannot answer that one, sorry.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.