Highlighted
Honored Contributor.
Honored Contributor.
427 views

Mismatch in the time showing in web and windows

Jump to solution

Hi Experts,

 

I am using SM 9.40. When I checked a date field in front end and back end, both where different.

For example the value of a field in front end is  05/24/17 17:00:00 and for the same record back end value is 2017-05-25 00:00:00.000.

Anyone please tell me a solution to make the front end value as same as backend.

 

Thanks & Regards,

Sandhu Mol

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Hi,

Is it just recently that this changed, or has it always been like this and you are just noticing now?  Which one is the correct one for you?

Long ago, when we were implementing, we had a time difference between what was showing in the app and what was showing in the database, and we determined that it was related to timezone, so after we set our system timezone in the app to show our correct time, we also set a parameter in the sm.ini to address the difference.

#Set the database time zone
sqltz:Canada/Eastern

I don't know if that is your issue, but it might be something to consider.  Make sure you test in a non-Prod environment before modifying your Prod environment.  Good luck.

Audrey

View solution in original post

2 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Hi,

Is it just recently that this changed, or has it always been like this and you are just noticing now?  Which one is the correct one for you?

Long ago, when we were implementing, we had a time difference between what was showing in the app and what was showing in the database, and we determined that it was related to timezone, so after we set our system timezone in the app to show our correct time, we also set a parameter in the sm.ini to address the difference.

#Set the database time zone
sqltz:Canada/Eastern

I don't know if that is your issue, but it might be something to consider.  Make sure you test in a non-Prod environment before modifying your Prod environment.  Good luck.

Audrey

View solution in original post

Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Few checks to be done as - Are both web and windows client users same? If both the logged on users are different then it might be a timezone setting that is related to operator record of the users. also check if there was any mimatch of time in the machines where HPSM is installed. 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.