Highlighted
Absent Member.
Absent Member.
362 views

PROBLEM changing default path SM

Hello,

 

i've received a request to change the default url used to reach SM.

In the example I want to pass from this

 

http://<IPOFTHESERVER>:8080/sm7/index.do

 

to this

 

http://<IPOFTHESERVER>:8080/sm7-test/index.do

 

I've tried different way but I can't find the right one.

The only one working is to change the directory

C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps\sm7

to

C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps\sm7-test

 

and restarting tomcat service.

This solution works but the installation loose all the branding made by HP for the customer.

 

I can't find any tomcat configuration file where "sm7" is used as default link.

 

Can you help me?

 

SM version 9.34

Tomcat version 7.0

 

Regards.

Luca

0 Likes
12 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: PROBLEM changing default path SM

Hi Luca

 

Seems you have deployed the war file to sm7-test from sm. so sm7-test is the OOB files in it.

 

Did you took the backup of sm folder before making these changes ? you may also need to copy the branding files from sm folder to sm7-test folder.

 

 

 

Thanks,

Deepesh
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: PROBLEM changing default path SM

Hi deepesh,

 

no no no, sorry, my fault during explanation.

The solution works and it loose all the branding, but if I rename the folder from "sm7-test" to "sm7" (and do a restart of the service) everything goes back to the right place. I haven't lost anything.

I'm searching for a way to do what I've done but without losing the customization.

 

Luca

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: PROBLEM changing default path SM

OK..so you have just renamed the folder. 

 

So do you know which files you modified for branfings , you have to change the urk there as sm7-test as well.

Thanks,

Deepesh
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: PROBLEM changing default path SM

Not for real, I know only some of them but I was expecting there was an absolute path in Tomcat easy to change to reach my objective.

I don't think renaming the folder is the right way. Am I wrong?

 

Thanks

Luca

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: PROBLEM changing default path SM

can't say, what you want to acheive by changing the name of the folder. also you have to follow below steps to change the folder name :-

 

1. Stop Tomcat service .

2. Rename the folder nams as well war file. sm7-test folder and same sm7-test.war file.  War file should be the same name for which url you want to access.

3. start the tomcat and check for url with sm7-test/index.do url.

 

Note :- if you haven't renamed the war file, then you must have seen another sm7 folder addtionally. 

Thanks,

Deepesh
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: PROBLEM changing default path SM

I can't found any ".WAR" file with the name like "sm7.war".

The only one is under

C:\Program Files (x86)\HP\Service Manager 9.30\Server\RUN\lib

 

and it's named "appserver-9.34".

 

In the folder sm7 under Tomcat there's no WAR file.

:(((

 

How can I proceed?

 

Luca

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: PROBLEM changing default path SM

is it not there in Tomcat>webapps folder ? i meab webserver.

 

and you renamed folder in webserver right ? then why are you checking application server , i am confused .

Thanks,

Deepesh
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: PROBLEM changing default path SM

No, there's no WAR file under "C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps".

 

The folder I've had renamed is under "C:\Program Files\Apache Software Foundation\Tomcat 7.0\webapps" and it's named "sm7".

 

There's no "webserver" folder on the server.

I've tell you about appserver because it was the only "war" file I was able to find.

 

Luca

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: PROBLEM changing default path SM

then you have to identify the files which was modified for branding. and change the folder from sm7 to sm7-test.

 

BTW, why do you want to change the folder name ??

 

 

 

Thanks,

Deepesh
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: PROBLEM changing default path SM

Because we have different instances (live, test, DR) and we're encountering issue with the redirect of an F5. We're trying do differentiate every instance to give to the F5 a different URI everytime.

 

I will continue to investigate.

Thanks for your answer.

 

Luca

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: PROBLEM changing default path SM

LUCA

 

Can you please check below settings :-

 

Specify the folder location in Web parameter: customize-folder.

For example:

<context-param>
  <param-name>customize-folder</param-name>
  <param-value>C:/customize</param-value>
</context-param>

 

 

Check the path given in customize-folder in web.xml file of tomcat. i assume you need change the folder name here as well.

 

 

Thanks,

Deepesh
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.