Highlighted
Absent Member.. Absent Member..
Absent Member..
1332 views

SM 7.10 + SM 7.00 KM Search Engine Setting Failure?

Hi, I download SM 7.10 Media from Partner portal and install it on a VM successfully. After I install KM Search Engine which is gotten for SM 7.00 version(Because there in't search engine in SM 7.10 media), I try to configure Search Engine on KM evironment, it is successful (Whatever "Verify Server" and "Verify Path" ).
But, when I want to reindex those knowledge library, there is a error message "Search Engine or Service Manager settings incorrect or not found! Please 1) configure the Knowledge Management Environment Settings, 2) go to the KMUpdate schedule record, set Status=rescheduled and Class=KMUpdate, and save, and 3) click Knowledge Management > Manage Updates and click Start."
I check the status of the process "KMupdate", which is "application failed due to error - check msglog for possible messages".
0 Likes
15 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Still couldn't resolve this issue after following the instructions in above thread.
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

check in the status TAB if kmupdate process is running only once.Sometime it starts in two and changes wont take place.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

If I restart KMupdate after I clear all records in kmknowledgebaseupdates table, the status of KMupdate still is "application failed due to error - check msglog for possible messages".
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Lets try following.

1a- Recycle KMsearch service.

1- Kill the KMUpdate process (using status windows).Make sure no KMUpdate process is showing up.



2- In schedule reschedule the KMUpdate process with back dates.

3- Restart KMUpdate process using ststus/start schedule menu.

4- check the KMUpdate index engine under Knowledge Management module menu. Should be showing number of records processed.

5. Now go to Manage Knowledgebases and try to get the information again. If status shows ONLINE.

6- Run search knowledgebase.

7- If errors attach sm.log and km enginelog for further insight.


hope this helps.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

I follow the above steps. After step 3, restart KMupdate process, I refresh the status of KMupdate from "Manage Updats" menu, the display is " KMUpdate scheduled
Idle Time : 00:01:35
Indexer Status: Running" , but other fields are blank.
Then I check the status of KMupdate using executing "s" command from "System Status", the process status is "application failed due to error - check msglog for possible messages".
I think the process started, then failed at once.
0 Likes
Highlighted
Absent Member.
Absent Member.

Hello, molihuacha.
Tell me please, what value you enter in the "Mapped Drive for Style Files" field.
The guide I read:
"If the search engine is installed on a separate machine, you need to share the stylesets folder from the search engine server to the Service Manager server. Use the share name and path for this setting so that the style files path in the environment form is set to stylesets folder.
Example:

C:\Program Files\HP ServiceManager 7.01\Search Engine\data\stylesets"

I share folder "C:\Program Files\HP ServiceManager 7.00\Search Engine\data\stylesets" on the server with search engine.
Smkm - name of the server.
And I enter in the "Mapped Drive for Style Files" field: \\win2k3srvx32-2\stylesets

But "Verify Path" show me:
"Failure! \"style.dft"\ not found at:
\\Smkm\stylesets/Def_FileSystem_PushAPI/style.dft"

0 Likes
Highlighted
Established Member..
Established Member..

Hi molihuacha,
Finally, did you resolve this failure??
I have the same problem and I don't know what is the problem. Could you help me?

Thank you,
Joana.
0 Likes
Highlighted
Absent Member.
Absent Member.

Has anyone stumbled on a fix for this yet?

I get the same message - listing what needs to be done.

I can confirm that I get connection to the host and that the stylesets can be found.

Changing the KMUpdate schedule has the same problems (i.e. it apparently dies right after)

In the schedule record though it refers to the km.check.stats RAD process. I viewed this process and found something that looked a little strange:
The last panel which is decide.exit, has the usual 2 exit labels (one for exit normal and the other for error) - both of these have the same value listed "$error" which means (at least to my understanding) that the only outcome for this last panel is to end up on the $error

Anyway that aside (I am most likely barking up the wrong tree) a solution to this problem is still required! The only other thing I can think of is the license string included in the .cfg file under the Search Engine install folder - could this be out of date???
0 Likes
Highlighted
Absent Member.
Absent Member.

There is a known problem documented in the Service Manager Online Help: Troubleshooting: Search engine fails to connect

Search engine fails to connect if installed anywhere except the default path (C:\Program Files...)

The simplest work-around is to start the Service Manager NT service as user Administrator.

Example:

SM 7.01 and KM SE installed on separate Windows 2003 Servers.

On the SM Windows 2003 Server,

1. Select Administrative Tools > Services
2. Select "HP Service Manager 7.01 Server"
3. Select the "Log on" tab
4. Select "This account"
5. Select "Browse"
6. Select "Advanced"
7. Select "Find Now"
8. Select the "Administrator" user
9. Enter the "Administrator" user password
10. Select Apply
11. Select Stop
12. Select Start
13. Select OK

On the KM SE Windows 2003 Server,

14. Share the stylesets folder. Make sure the user you are starting the SM service as (Administrator) has full permissions to the share.

Working as user falcon using the SM Windows Eclipse client,

15. Load the knowledge Management Environment record

Menu Navigation > System Administration > Ongoing maintenance > Environment Records > Knowledge Management Environment

16. Enter the share name e.g.

Mapped Drive for Style Files = \\\data\stylesets

17. Select Verify Path

Provided the share permissions have been configured correctly Verify Path should now return a success message.
Without these forums many of us would be dead
0 Likes
Highlighted
Absent Member.
Absent Member.

In our environment we have the server drive partitioned, using C: for OS specific files and a 😧 partition for application install.

Both Service Manager and the Search Engine are installed onto:
D:\Program Files\HP\Service Manager 7.10\...

While this is not the default C:\Program Files...

I am able to get a "Successful" message when the verify path is clicked for the Style files. This to me indicates that there are no issues (sharing or otherwise)on the system being able to access the mapped location. I am also shown a "Conneted" message when the verify host server button is clicked.

What the problem seems to be, is that the KMUpdate process is unable to run without reporting an error and failing. To confirm this the connection status for each library record under manage knowledge bases is listed as "offline".

So - all this advice is helping to eliminate possibilities, but not providing any solutions. No resolution from HP yet either.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.