Highlighted
DV_2 Super Contributor.
Super Contributor.
1143 views

SM 9.30 SSL Login Issue

Hi, 

 

I have created the certs and implemented it successfully along with Apache and Tomcat. Since the users are web based, I have not configured SSL for windows client.

 

When I try the url, http://smapdev.domain.local/sm9/ it is prompting me to enter user id and password (since I'm not logged in as domain user). Once I have entered a domain user id and password (operator account exist in SM), it opens the SM login page (like normal webclient), instead of opening up the to do queue. 

 

I know the domain user id and password are correct. If I enter a wrong password, it got a message saying "Authentication Failed".

 

Any idea where's the issue?

 

Regards,

DV

0 Likes
4 Replies
ramesh9 Acclaimed Contributor.
Acclaimed Contributor.

Re: SM 9.30 SSL Login Issue

I am not sure on SM 9.30, but the URL you need to pass is,

 

http://smapdev.domain.local/sm9/index.do

DV_2 Super Contributor.
Super Contributor.

Re: SM 9.30 SSL Login Issue

Hi Ramesh, 

 

Still the same. Even i tried http://sm-apdev.domain.local/sm9/index.do. It asks for the user id password and then shows the login page. 

 

Regards,

DV

0 Likes
Absent Member.. Bruno_De_Graeve Absent Member..
Absent Member..

Re: SM 9.30 SSL Login Issue

I suppose you want to setup Single Sign On (SSO) of which the SSL setup is prerequisite n°1. the second prerequisite is having an external authentication source like IIS Integrated Windows Authentication, CA Siteminder, IBM Webseal, etc.

 

If you want to avoid the login page. Please consult the help and serach for single/trusted sign-on.

 

In a nutshell you need to set isCustomauthentication to false in web.xml, add a bean in application-context.xml, add trustedsignon/1 in sm.ini, disable Tomcat authentication in Tomcat's server.xml, enable only IWA in IIS. If you have basic and IWA authentication enable in IIS, you always get the prompt.

Add your URL to the trustes sites in IE and enable pass trough authetication for trusted sites.

In other words, revise the SM7 SSO White Paper.

 

regards, Bruno

DV_2 Super Contributor.
Super Contributor.

Re: SM 9.30 SSL Login Issue

Hi Bruno, 

 

I'm able to login now. Missed to add the tomcatAuthentication="false" parameter in tomcat's server.xml file. 

 

<Connector port=”8009”
enableLookups="false" tomcatAuthentication="false" redirectPort="8443"
debug="0" protocol="AJP/1.3" />

 

 

Now I have another issue with SM web client 9.30 021. The menu navigator and ticket list are not displaying. Cleared the cache (both at client side as well as tomcat side). Still not displaying. 

 

Need to check the patches. 

 

Regards,

DV

 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.