hsidani Respected Contributor.
Respected Contributor.
792 views

SM-RC integration Issue

Jump to solution

Hi Experts,

 

I'm trying to integrate Release control 9.20 with service manager 9.31 using SSL. But I'm getting an error while I'm creating the integration package as the per the attached figure.

 

I've tried to access the link

 

HTTPS://myservername:13443/sc62server/PWS/ChangeManagement.wsdl 

 

but it is not accessible.

 

Kindly advice

 

Thanks and Regards

 

Hani

0 Likes
1 Solution

Accepted Solutions
hsidani Respected Contributor.
Respected Contributor.

Re: SM-RC integration Issue

Jump to solution

Hi Viprom,

 

Finally it is working. As you mentioned before that we have to check it no and from the integration properties I have changed all HTTP links to HTTPS and the ports to 13443. then it worked.

 

 

Thanks for your help

 

Regards

 

Hani

View solution in original post

0 Likes
7 Replies
Absent Member.. viprom Absent Member..
Absent Member..

Re: SM-RC integration Issue

Jump to solution

Hi Hani,

 

Check this KM doc: http://support.openview.hp.com/selfsolve/document/KM00276004

There you can find detailed instructions on how to integrate SM and RC with SSL encryption and LW-SSO.

 

Other than that, have you checked if the port is correct one? You may also try using the FQDN of the server instead "myservername".

 

Let us know about your results.

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks 🙂
0 Likes
hsidani Respected Contributor.
Respected Contributor.

Re: SM-RC integration Issue

Jump to solution

Hi Viprom,

 

Thanks for your prompt reply.

 

Actually I have followed the KM00276004 document to setup RC with Sm but I'm facing problem with the integration package only. Everything else is working fine (LWSSO and SSL Encryption)

 

Regarding myservername, I've mention it as an example but I'm using the  FQDN of the server.

 

 

Thanks again,

 

Regards

 

Hani

0 Likes
Highlighted
Absent Member.. viprom Absent Member..
Absent Member..

Re: SM-RC integration Issue

Jump to solution

Ok, this makes sence.

I have check the screenshot you attached and noticed you picked "y" on the question "Is https required in order to access wsdl?". Have you tried with chosing "n". According to the SM Helpserver (check section Configure the RC adapter) you need to pick "n".

Let us know if this makes it work.

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks 🙂
hsidani Respected Contributor.
Respected Contributor.

Re: SM-RC integration Issue

Jump to solution

Hi viprom,

 

yes I have tried checking no. It will work but not over SSL. In the integration properties inside Release control all the links will be http (Http://s-mds-sm.itsm.local:13080/sc62server/ws). And from the Service manager side I was not  able to view the calendar since it is not a secure content. (SM is configured to use TSO)

 

 

Thanks and Regards

 

Hani

0 Likes
hsidani Respected Contributor.
Respected Contributor.

Re: SM-RC integration Issue

Jump to solution

Hi Viprom,

 

Finally it is working. As you mentioned before that we have to check it no and from the integration properties I have changed all HTTP links to HTTPS and the ports to 13443. then it worked.

 

 

Thanks for your help

 

Regards

 

Hani

View solution in original post

0 Likes
Absent Member.. viprom Absent Member..
Absent Member..

Re: SM-RC integration Issue

Jump to solution

Great news! 🙂

yes, the default https port is 13443.

by the way, not sure if you have noticed this, but on the question "Is https required in order to access wsdl?" the only option is "n".

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks 🙂
0 Likes
hsidani Respected Contributor.
Respected Contributor.

Re: SM-RC integration Issue

Jump to solution

Hi Viprom,

 

Yes you're right, it is the only option. 

 

Anyway thanks a lot and have a great day

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.