Highlighted
Established Member..
Established Member..
860 views

SM Service Portal - Not able to add SM as Supplier

Jump to solution

Error1.pngDear All,

We have installed SMSP 9.51 successfully and trying to add "HP Service Manager" as supplier.

Issue now faced is we are not able to add SM as “Supplier”, it shows the error as “Failed to load list of system types”.

 Below are the steps followed to add supplier.

1). Login to SMSP 

2). Use “orgadmin” account to login

3). Click on “Suppliers” and then “Add Suppliers

Below error messages appears

"Failed to load list of system types"

Error Secreenshot is atatched 

Has anyone else faced such issue ?

Regards,

0 Likes
1 Solution

Accepted Solutions
Highlighted
Established Member..
Established Member..

Re: SM Service Portal - Not able to add SM as Supplier

Jump to solution

Hi,

For me this issue was resolved after following the below steps.

1.Restart Service Manager Service Portal and OO:

# propel stop

-Clear all logs into jetty-sx directory + notification

# propel start

# systemctl restart central.service

2. Verify that the Portal service has initialized properly and restart if necessary:

# systemctl status portal

Sx-trace.log should have no error before adding new supplier. If this is happen what I do is

Restart jetty with reset logs files -> if any error found then, first resolve the issue.

If no error in jetty(sx-trace.log and other ) then, try to add new supplier.

Regards,

View solution in original post

0 Likes
2 Replies
Highlighted
Established Member..
Established Member..

Re: SM Service Portal - Not able to add SM as Supplier

Jump to solution

I was originally able to select 'SM' as a supplier early on after my SMSP v9.51 install. However during the process of adding a supplier it asks for the LWSSO init string. So I went back and setup LWSSO as per the install guide,  replaced the self signed certs, and replaced the trial license. Now I get the same error as you. I will test the impact of rolling back to the self signed certificates to see if that resolves the issue.

0 Likes
Highlighted
Established Member..
Established Member..

Re: SM Service Portal - Not able to add SM as Supplier

Jump to solution

Hi,

For me this issue was resolved after following the below steps.

1.Restart Service Manager Service Portal and OO:

# propel stop

-Clear all logs into jetty-sx directory + notification

# propel start

# systemctl restart central.service

2. Verify that the Portal service has initialized properly and restart if necessary:

# systemctl status portal

Sx-trace.log should have no error before adding new supplier. If this is happen what I do is

Restart jetty with reset logs files -> if any error found then, first resolve the issue.

If no error in jetty(sx-trace.log and other ) then, try to add new supplier.

Regards,

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.