Highlighted
Respected Contributor.
Respected Contributor.
524 views

SMA-SM - Cannot login to the installation portal

Jump to solution

After deploying the CDF core content I cannot login to the Installation Portal.

When I load the URL: https://servername.domain.com:3000 the login page appears.

I can fill the userid and password fields, but when I click on login the browser stucks in Loading ..... and nothing heapens.

The pods are started succesfully and I can't see anything wrong in the logs.

Could someone tell me what could be the problem?

0 Likes
1 Solution

Accepted Solutions
Highlighted
Respected Contributor.
Respected Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

I've got a solution from Support.

We had to set the following permission in order to installer to be able to read the suite metadata:

chmod 755 -R /opt/kubernetes/cfg/suite-metadata/

View solution in original post

8 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

I have noticed that reboot sometime helps in this case. Has twice in SMAX install same issue.

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

Hello Misaq,

Thanks for you answer!

I've rebooted the system but the situation is the same.

The question is actually that how can I check if the install frontend is functioning correctly?

I checked the POD's log files, but nothing special in them.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

Unfortunately I have not experineced this yet. But for troubleshooting may be following would help:

  • check kube-status.sh   output
  • check kube-start.log (might be a dufferent name(its in either /tmp or under kubernetes folder).
  • try different browser.
  • "loading..." issues I had were mostly in 2018.02 and 2018.05 CDF  after launching the installation portal but only once I had to re-install otherwise reboot helped.
  • If you look in the log folder under /opt/kubernetes    one of them should be indicating the error
  • Also follow the troubleshooting section : https://docs.microfocus.com/itom/Service_Management_Automation_-_SM:2018.08/Troubleshoot-CDF_19895252
0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

I've rebuilt it from scrach and still the same.

But the source of the problem should be this:

E0115 14:31:45.048841 4879 proxier.go:584] Failed to execute iptables-restore for nat: exit status 1 (iptables-restore: invalid option -- '5'
Try `iptables-restore -h' for more information.
)
E0115 14:31:45.055563 4879 proxier.go:610] Failed to execute iptables-restore for filter: exit status 1 (iptables-restore: invalid option -- '5'
Try `iptables-restore -h' for more information.
)
E0115 14:31:45.069480 4879 proxier.go:792] Failed to execute iptables-restore for nat: exit status 1 (iptables-restore: invalid option -- '5'

One thing that is more interesting: I have a conrol machine with CentOS (where everithing works) and with the same version of iptables-restore v1.4.21

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

Have you triend disabling the firewall?(I am guessing you are in testing mode for now)

I think its in the instruction.

systemctl stop  firewalld

systemctl disable firewalld

also  disable selinux

 

This should rule out the iptable issue. ALso if you are using browser from other client , can try locally on the server to test if something blocking it there.

Highlighted
Respected Contributor.
Respected Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

Yes, I went through these things.

Firewall disabled, selinux permissive and this is a minimal install without X, so I can not run local browsers.

The frontend keeps tracking where we are and when I interrupt the configuration and load again the frontend, it knows where were we previously. Do you know where this information is stored?

0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

I've got a solution from Support.

We had to set the following permission in order to installer to be able to read the suite metadata:

chmod 755 -R /opt/kubernetes/cfg/suite-metadata/

View solution in original post

Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: SMA-SM - Cannot login to the installation portal

Jump to solution

strange. I have this setting usually when Install. There might be something wrong with the installation process.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.