New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Commander
Commander
5370 views

SRC service catalogue not available

Hello to everybody,

 

We have deployed a new SM9.30 environment and upgraded to 9.31 as per HP documents instructions. Configured SD & IM modules succesfully and utilized TSO (SSL with an IIS web proxy) for web clients (ESS & webtier) ...

 

SM server is running both on port 13080 (https) and on port (13085) (http) so we can have clients with http/https connections to it.

 

We have deployed a second apache tomcat without https support to run on port 8081 and we have tried to deploy SRC web client (1.40) to it.

 

SRC is configured without TSO support to 13085 port and it is configured according to HP SRC installation manual.

 

SRC client starts fine, operators are authenticated BUT the "Browse Catalogue" option is not available as also any relate to service catalogue views.

 

From windows client the service catalogue is available and populated with the OOB data.

 

Have read and followed instructions posted here:

 

http://h30499.www3.hp.com/t5/HP-Service-Manager-Service/Service-Catalog-issue/m-p/5966211/highlight/true#M97711

 

but no solution.

 

Checked in the tomcat server.log and i find:

 

Spoiler
27 Ιουν 2013 13:52:23,932 INFO [localhost-startStop-1] (AuthChallengeProcessor.java:101) - basic authentication scheme selected
27 Ιουν 2013 13:52:23,932 INFO [localhost-startStop-1] (HttpMethodDirector.java:722) - Failure authenticating with BASIC 'CASM'@as005g215.cy.hellenicbank.net:13085
27 Ιουν 2013 13:52:23,932 ERROR [localhost-startStop-1] (ServiceException.java:92) - [SBP111] Incorrect credentials
27 Ιουν 2013 13:52:23,932 FATAL [localhost-startStop-1] (CatalogLifecycleManagerImpl.java:600) - [Load Catalog: sm ] Error authenticating catalog org.springframework.security.authentication.UsernamePasswordAuthenticationToken@642ac6fc: Principal: srcadmin; Credentials: [PROTECTED]; Authenticated: false; Details: org.springframework.security.authentication.AuthenticationDetails@6cb00a9c: Context: sm; Not granted any authorities. *Root cause*: com.hp.siberia.exception.ServiceException: Incorrect credentials
com.hp.siberia.exception.ServiceException: Incorrect credentials

 

I am attaching the relevant log ... Any ideas ???

Tags (1)
0 Likes
4 Replies
Highlighted
Cadet 1st Class
Cadet 1st Class

Hi

I see that you have an authentication problem

Make sure that you use double \\ backslash on the path were you specify the file that contain the encrypted key

Here is an example of the parameter that is specified in applicationContext.xml file for SRC 1.40:

 

src.encryption.file.name=C:\\Program Files\\Apache Software Foundation\\Tomcat 7.0\\src-1.40\\password.txt

 

that should solve your authentication problem

Highlighted
Absent Member.
Absent Member.

Hi,

 

You can also follow the below steps for SRC 1.4:

 

 

1. Stop SRC

2. Ensure the following parameters have been set correctly in the SRC applicationContext.properties file:
sm.adminCredentials
src.encryption.file.name

3. Delete all log files from the web application server 
example:  C:\Program Files\Apache Software Foundation\Tomcat 7.0\logs

4. Delete the web application server cache 
example:  C:\Program Files\Apache Software Foundation\Tomcat 7.0\work

5. Delete all files\folders in the <SRC INSTALL DIRECTORY>\secure\attachments folder

6. Delete the SRC lucene index

example:  delete the folder in <SRC INSTALL DIRECTORY>\secure\luceneIndexedData

7. Start SRC


Assign Kudos by clicking on Star on your left ,if this post helped you in any manner...Thanks...

Gaurav
Highlighted
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Hi Experts,

 

After implementing the above mentioned points also we are getting the same error message and SRC is not launching successfully. Quick help on this issue would be much appreciateble.

 

Regards,

Sridhar D

0 Likes
Highlighted
Cadet 2nd Class Cadet 2nd Class
Cadet 2nd Class

Hi Experts,

 

We are facing this issue still in our environment. Any help on this issue would be highly appreciatable. Kindly let me know for further details. Thanks

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.