Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Have you tried it without the ".exe"?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Hi:

Abel, thanks for your answer.

In logserver file I have seen the following one:

Tue, 25/03/2008 10:32:23 Rule: BannerYellow Banner (Acción de ejecución de comando) Agent: PO000INF004.abm.corp.local: not responding (machine switched off?).


The PO000INF004.abm.corp.local client is on which I am making tests. In logagent file (client machine) doesn't appears any line from today.

Regards,

David
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Hi David,

To switch on Rule debug, go to Tools>System>System Panel>General settings and it is at the bottomm of the screen.

Regards, Ruth
http://www.teamultra.net
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Have you checked the account:person:host


This is found in the application accounts; there will be a field called "Host", check that this is the name of the machine you are testing on.

Also check name resolution (DNS records)
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Hi:

This is the new log appeared in logserver file on windows server:

Tue, 25/03/2008 10:54:12 Rule: BannerYellow Banner (Acción de ejecución de comando) Agent: PO000INF002.abm.corp.local: not responding (machine switched off?).
Tue, 25/03/2008 10:54:33 Unable to connect to host: po000inf002.abm.corp.local on port:40999
Nested exception is:
java.net.ConnectException: Connection timed out: connect
at com.hp.ifc.net.tcp.AppTcpConnection.(Unknown Source)
at com.hp.ifc.net.itp.AppItpClient.initConnection(Unknown Source)
at com.hp.ifc.net.itp.AppItpClient.(Unknown Source)
at com.hp.ifc.net.itp.AppItpClient.getClientFor(Unknown Source)
at com.hp.ifc.net.itp.AppItpClient.remoteInvoke(Unknown Source)
at com.hp.ifc.net.itp.AppItpProxy.__objectInvoke(Unknown Source)
at com.hp.ifc.net.itp.AppItpProxy.__voidInvoke(Unknown Source)
at com.hp.ifc.net.mq.ps.PAppMessageQueue.put(Unknown Source)
at com.hp.ifc.net.mq.AppMessageQueue.send(Unknown Source)
at com.hp.ifc.net.mq.AppMessageQueue.send(Unknown Source)
at com.hp.itsm.srv.SrvWorkFlow.sendOnlineMessage(Unknown Source)
at com.hp.itsm.srv.SrvWorkFlow.access$000(Unknown Source)
at com.hp.itsm.srv.SrvWorkFlow$2.run(Unknown Source)
at com.hp.ifc.util.AppThreadPool$PoolThread.run(Unknown Source)

In the application accounts, the names are correct and are unlocked.

Thanks very much,

David
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Hi David,

The log file says the agent is not responding - can you check the agent is in fact running on the target machine.

Hope this helps,Ruth

PS dont forget to assign points
http://www.teamultra.net
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Can you try a different machine; as well as a different account?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Hi, David,

for troubleshooting purpose, you can try to put the IP address of the machine where the agent is running into host field (see attachment).

Is there a firewall running on the machine?

Jitka
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Hi again:

Sorry very much for the delay, but I've been quite busy with other tasks. I've proved putting only ip address and it doesn't run successfully neither.

I've seen that it appears an service desk icon with a notification from one new assigned record, but the banner doesn't appears.

I've the client machine into active directory, and I've been enabling as the port as the command (banner.exe, with absolute path) in windows firewall. Only appears icon with notification.

Any ideas?? Thank you very much,

David
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
hi!

1.Is the firewall on in Server and the PC where the banner should run ? If so, try to stop it for a while and test.
2. Are you able to ping from server-PC and PC to server, By ip and by PC/.Server name ?
3. Have you installed servicedesk agent in the PC ?
4. Is the service desk agent patched, same as the server ?
5. Is the sd agent running ?
6. Are you seeing any errors in the log file of SD Agent ?

Check these and let us know the status. Alos, please publish the DB rule, which you are using.

Ashly A K
http://www.geocities.com/helponhpopenview

View solution in original post

Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Thank you very much everybody. Finally, the problem has solved. When I desactivated the windows firewall on clients, the banner has appeared. Then, I added the 50998 and 30999 ports like exception in windows firewall, and the banner appears OK.

Thank you again,

David
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service Desk 4.5 banner problem

Jump to solution
Great!!!!
http://www.geocities.com/helponhpopenview
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.