Highlighted
Absent Member.. Absent Member..
Absent Member..
64 views

Service Manager Integration Manager Task Failures for OMI Integration

Hello I am using SM 9.30 and we have an Integration to OMI.  I have 2 issues currently with this integration that I'm hoping you can help with.

1) Whenever some special characters such as ' or \ are found in our OMI generated Tickets and we close the ticket, SM should talk to OMI and close the related alert.  Instead we are receiving a failure.  We have found that when SM passes the data back to OMI, it is not handling those characters and OMI considers them invalid XML therefore it fails.  Shouldn't SM automatically take care of this through the integration?  It is not uncommon for us to have \ as part of a file patch in our tickets, especially for tickets opened from application logs.  We do not want to add processing time by writing custom code to somehow resolve these characters, seems like this should be within the integration.  OMI has no problems sending the characters to SM and SM has no trouble opening the tickets that have these characters in them.

 

2) When we have failures from the above situation, we see them in the SMISTaskQueue Table, it appears to us that SM is constantly trying to reprocess these and the Max Retry Time is always set to 0 (this never changes).  We thought that these would only be tried again according to the retry parameters set on the OMI integration in Integration Manager.  Is this something that is broke in SM 9.30?

0 Likes
1 Reply
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Service Manager Integration Manager Task Failures for OMI Integration

Hi tsdc,

1. If I understand this correctly, when SM returns the data back to OMI, it sends it in a format that is invalid to OMi, which means SM cannot handle the characters according to your explanation but when OMi sends them, SM do respect them. If SM pushes back the characters in XML correct format/syntax and OMi fails, why this is a SM problem? or SM is not sending the correct XML syntax back to OMi and because of that it's failing? What I'm trying to determinate here is if SM is guilty of the problem or OMi should be the one that is not handling the characters correctly.

2. This is how Integration Manager is suppose to work:

a. When enable SMOMI integration intergration manager(Intervals = 30, Max Retries = 10):

One schedule record with class = SMOMi is created and the repeat interval is 00:00:30

One background process with name = SMOMI is started

b. When an SM operator update an incident from OMI, but sync to OMI failed, one task record is added to Intergration Manager Task, with retries = 0 because now it has never retry to sync back to OMI side

c. After SMOMI bg run and execute SMOMI schedule, task retires will change to 1, and then 2, 3, 4…

d. When retries exceed max retries defined(e.g. 10), task will be expired

So basically if retries are never updated either the schedule record doesn't have the correct info, bg process for SMOMi is not running normally or maybe the integration manager point is corrupted.

You might want to recreate it and check if the behavior remains the same.

If it does, I think a trace of the bg process will be required for get more details.

Regards,

SM Support Engineer

Thank you for using the Micro Focus Community. If you find that this or any post resolves your issue, please be sure to mark it as an "accept as solution".
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.