Highlighted
Absent Member.
Absent Member.
841 views

Skip "Solution Matching" for Incidents in 9.40

Jump to solution

Dear All,

In HPSM 9.40, need your guidance to skip "Solution matching" page which comes after we click on "Escalate" button in interaction module.

Attached the screenshot of the page for reference. Any help is highly appreciated.

Regards,

Madhu

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Fleet Admiral
Fleet Admiral

Hi Madhu,

There is a Process record called during escalation called sd.escalate.  In the RAD tab of that Process record there is a RAD application called incident.matching with a condition of:

jscall("ServiceDeskSwitch.getSDSwitch")=false and $G.bg=false and $L.continue and $L.exists=true and ($L.escalateRelation="Escalated Incident" or $L.escalateRelation="Escalated Request" or $L.escalateRelation="Escalated Problem")

You could either manipulate that condition directly to set it to false, or determine if there is a way to make that condition evaluate to false.  When I tested setting it to false directly the Incident Matching screen did not come up and instead I was taken directly to the new IM ticket.  I hope this helps.

Audrey

 

 

View solution in original post

4 Replies
Highlighted
Absent Member.
Absent Member.

Just to add,

I have already tried the below methods, but none were successful

1. In the table imMatchQuery deleted all of them ,

2. In Incident workflow removed "Incident matching" ruleset

Looking forward for your reply guys.

Regards,

Madhu

0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

Hi Madhu,

There is a Process record called during escalation called sd.escalate.  In the RAD tab of that Process record there is a RAD application called incident.matching with a condition of:

jscall("ServiceDeskSwitch.getSDSwitch")=false and $G.bg=false and $L.continue and $L.exists=true and ($L.escalateRelation="Escalated Incident" or $L.escalateRelation="Escalated Request" or $L.escalateRelation="Escalated Problem")

You could either manipulate that condition directly to set it to false, or determine if there is a way to make that condition evaluate to false.  When I tested setting it to false directly the Incident Matching screen did not come up and instead I was taken directly to the new IM ticket.  I hope this helps.

Audrey

 

 

View solution in original post

Highlighted
Absent Member.
Absent Member.

Hi Audrey,

Even I figured out at the same time. Thanks Audrey for your kind reply and suggestions.

Regards,

Madhu

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

You can also just de-select all of the incident matching options in the user's IM profile (classic) or disable all matching options in the module settings (codeless).

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.