Highlighted
Contributor.. Contributor..
Contributor..
285 views

Smart Email - 504 Error

Hi All,

 

I have been working on setting up the Smart Email integration via EWS, so far, so good.

 

One issue I have come across is that the system does not generate the interaction from the email that is sent.

 

I send it from my own address to the service desk mailbox.

it says that is it successfull, but when I go an look into the Task Logs, it shows:

 

05/02/18 13:12:46 Australia/West Created Task to process: 8

05/02/18 13:12:47 Australia/West Picked up Task 8 for processing

05/02/18 13:12:48 Australia/West Task 8 successfully processed for record External ID null and Internal record null. <Event add> With error message: Email Send to Sender: Marcel.WOLF@************** for error: 504 [Failed to create the record due to insufficient user right]

It should be noted that my operator account is a sys admin, so it has more then sufficient permissions. (admin in every module)

Is there something else that I should look at to establish where the fault is?

Thanks in advance,

Marcel

0 Likes
2 Replies
Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..

Re: Smart Email - 504 Error

Hello Marcel,

 

I have faced a similar problem in the recent past. The culprit was that I used my email address for several "test" users.

So, whenever I sent an email to be processed by Smart Email, HPSM searched through the operators records and the first time that an operator's email matched the email's "From" field, it assumed that it found who sent it.

If the first "match" is with an operator without sufficient rights, the record will not be created.

For Smart Email to work correctly, consider the email address of every operator as a unique key.

 

Tell me if that worked out for you.

0 Likes
Highlighted
Contributor.. Contributor..
Contributor..

Re: Smart Email - 504 Error

Hi Ioannis,

Thanks for the reply!

I have already checked whether or not it was my operator account causing the issues, as well as checking whether my email was used in mulitple accounts... but every user that has sent an email to the mailbox gets the same 504 error.

It should also be noted that with our current system, this was upgraded from 9.30 - 9.52 hybrid, so it still runs some of the legacy "user profile" security, as well as secArea and secRole.

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.