Highlighted
Established Member..
Established Member..
96 views

SmartEmail get stuck with error Character reference "&#x19" is an invalid XML character.)]:undefined

The SmartEmail integration has stopped processing all the emails from the inbox (we are use an O365 account and works with EWS protocol) but the SmartEmail integration, the processes SmartEmail4 & SmartEmail_Processor and the scheduled  processes SmartEmail4 & background SmartEmail processor still running correctly.

The only clue I could find was these following errors on SmartEmail-20200408.log

04/08/2020 16:57:43 13252( 38165) SMIS [ERROR][Error in MailReceiver.receiveMsgIdList. exception:Error calling method: getMsgIdList in class: com/hp/ov/sm/server/utility/htmlemail/MailReceiver Exception (microsoft.exchange.webservices.data.core.exception.service.remote.ServiceRequestException: The request failed. ParseError at [row,col]:[14,50]Message: Character reference "&#x19" is an invalid XML character.)]: undefined


04/08/2020 18:17:47 13252( 38164) SMIS [ERROR][Can not move the mail. Exception: ]: Error in MailReceiver.moveMessage. exception:Error calling method: moveMessage in class: com/hp/ov/sm/server/utility/htmlemail/MailReceiver Exception (microsoft.exchange.webservices.data.core.exception.service.remote.ServiceResponseException: The specified object was not found in the store., The process failed to get the correct properties.)


04/08/2020 18:17:53 13252( 38164) SMIS [ERROR][Can not move the mail. Exception: ]: Error in MailReceiver.moveMessage. exception:Error calling method: moveMessage in class: com/hp/ov/sm/server/utility/htmlemail/MailReceiver Exception (microsoft.exchange.webservices.data.core.exception.service.remote.ServiceResponseException: The specified object was not found in the store., The process failed to get the correct properties.)


04/08/2020 18:17:58 13252( 38164) SMIS [ERROR][Can not move the mail. Exception: ]: Error in MailReceiver.moveMessage. exception:Error calling method: moveMessage in class: com/hp/ov/sm/server/utility/htmlemail/MailReceiver Exception (microsoft.exchange.webservices.data.core.exception.service.remote.ServiceResponseException: The specified object was not found in the store., The process failed to get the correct properties.)

Any idea that how I can fix these errors?

I hope I have explained myself well.

Thank you.

0 Likes
1 Reply
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: SmartEmail get stuck with error Character reference "&#x19" is an invalid XML char

Hi,
This is related with a known issue residing in EWS API about the invalid characters in emails.

Here are the PR in github and the detail about the known issue.
https://github.com/OfficeDev/ews-java-api/pull/409
https://github.com/OfficeDev/ews-java-api/issues/534

Probably the & is making the character invalid.

Additional Information:
All the characters which match the following regular expression are valid in xml1.0.
Char::= #x9 | #xA | #xD | [#x20-#xD7FF] | [#xE000-#xFFFD] | [#x10000-#x10FFFF] /* any Unicode character, excluding the surrogate blocks, FFFE, And FFFF. */

Please contact Microsoft to find a fix

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.