Highlighted
Absent Member.. AWHITE Absent Member..
Absent Member..
148 views

Support tip: 9.30 load balancing issue

Hello all,

 

Problem  App servers need to communicate to each other. When the services are started, they communicate properly. Soon after, they stop communicating with each other.  In a Horizontally Scalled Service Manager environment, how do you limit the multicast traffic to only broadcast between the SM nodes?

 

DetailsThe customer network admin wants to know if the HP servers respond ARPs request using multicast MACs?  The reason of the question is because Cisco is trying to assist they with their network configuration. They know for a fact that multicasting in our staging network environment (where the problem is) is not setup properly for HPSM. They believe this to be the root cause of the multicast failures with the application. Once They get the network configured properly they can verify that the application is working properly. Cisco’s questions are to help implement the correct network solution while not negatively impacting their network.

 

Solution: Turn multicasting on certain switches.

 

Solution details:

see: http://www.tldp.org/HOWTO/Multicast-HOWTO-2.html , Service Manager requires a Level 2 conformance of UDP multicasting. However, you can throttle down the amount of hops a UDP broadcast will take from the SM server out to your network. This is controlled via TTL.

 

In the <Service Manager>\<Server>\RUN directory, there is a file called UDPcluster.xml. This file is basically the multicast configuration file for SM. You need to change the ip_ttl parm to control how far SM will broadcast via UDP. The default is 32 hops: ip_ttl="${jgroups.udp.ip_ttl:32}"

 

What you will need to do is count how many routers are between the SM nodes and include the server you are on.

 

Example:

 

If you have two routers between the SM nodes, then you would set the following: ip_ttl="${jgroups.udp.ip_ttl:3}"

 

When SM broadcasts, it will count backwards staring with itself: SM LB server will be 3 >>> first router will be 2 >>> 2nd router will be 1 >>> SM 2nd node will be 0

 

This setting should limit the broadcasting to a small amount of hops and not broadcast over your entire network. 

 

If you have anything additional to add, please respond below so everyone may benefit from the extra information.  Thank you.

 

Regards,

 

Andrew

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Labels (1)
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.