Highlighted
Absent Member.
Absent Member.
1465 views

Unexpected error during login

Jump to solution

Hello, friends!

After rebooting server I can't log in HPSM - displays an error message "Unexpected error during login".

 

Part of sm.log with error:

2648(  3680) 05/06/2015 12:12:05  RTE E _getLicenseInfoEntityForUpdate(): Error getting license info from database
2648(  3680) 05/06/2015 12:12:05  RTE E User abdulkin login failed.

 

 

Can anyone help me?

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Hello!

 

The followings messages:

 

2648(  3680) 05/06/2015 12:12:05  RTE E _getLicenseInfoEntityForUpdate(): Error getting license info from database
2648(  3680) 05/06/2015 12:12:05  RTE E User abdulkin login failed.

 

The cause of these messages are for an unknown reason, there is no entry in the LICENSEINFOM1 table. It is possible that the application didn't shut down properly. The current active license information is stored in this table. If it is empty, users won't be able to log in.

 

The fix is to restart the SM Services, and if they won't stop properly, run the sm -shutdown:1 command in a Windows environment (or smstop -f in a Unix environment). Then start the SM Services. Make sure an entry is written to the LICENSEINFOM1 table.

 

Regards!

 

 

View solution in original post

5 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Hi,

 

I can't speak specifically to the error you've mentioned, but are you sure your Service Manager license hasn't expired?   That's the only time I've gotten license type messages after a reboot.

 

If you run a license report from a command prompt on the Service Manager server you should be able to tell, or at least eliminate an expired license as the cause.

 

Audrey

 

 

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Hello!

 

The followings messages:

 

2648(  3680) 05/06/2015 12:12:05  RTE E _getLicenseInfoEntityForUpdate(): Error getting license info from database
2648(  3680) 05/06/2015 12:12:05  RTE E User abdulkin login failed.

 

The cause of these messages are for an unknown reason, there is no entry in the LICENSEINFOM1 table. It is possible that the application didn't shut down properly. The current active license information is stored in this table. If it is empty, users won't be able to log in.

 

The fix is to restart the SM Services, and if they won't stop properly, run the sm -shutdown:1 command in a Windows environment (or smstop -f in a Unix environment). Then start the SM Services. Make sure an entry is written to the LICENSEINFOM1 table.

 

Regards!

 

 

View solution in original post

Highlighted
Absent Member.
Absent Member.

Shutdown the SM, and execute command

sm -unlockdatabase

 

then restart and try to login.

 

After restart check the sm.log file for any error(before trying login)

____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
0 Likes
Highlighted
Absent Member.
Absent Member.

Thanks to everyone who pitched in and helped!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.