Highlighted
Absent Member.
Absent Member.
4843 views

Very Urgent!!! - Unable to login to webclient

Jump to solution
Hi, I am not able to access hp service manager through web client, but I am able to access it via windows client. However, all these days I was accessing windows client through the port 13081 and had observed in web.xml file the port mentioned was 13080, but still everything was working fine all these days. From yesterday I am unable to access web client. Now I changed the port from 13080 to 13081 in web.xml file, but still the same issue. PFA I have even changed the parameter secureLogin to false in web.xml file, but still no luck Regards, Madhu “Any help is highly appreciated”
0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi

What is your jdk version? Webserver version/SM version?

 

I guess you have done "stop -> start" of your Web application server (and SM server), after all these changes you described?

 

If you have configured SSL, check its configuration.

You may also try to recreate the SSL Certificates if any ..

 

Another thing, if your environment is loadbalanced -> there was such an issue before because in sm.cfg the parameter loadBalancer was not correctly spelled. (it was loadbalancer instead of loadBalancer). So you may check that as well.

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks 🙂

View solution in original post

Tags (1)
10 Replies
Highlighted
Absent Member.
Absent Member.
even tried by setting honorUrlPort to true in web.xml , still no luck.. Got to know that 13080 is the SSL port and 13081 is a normal port used to access service manager. So 13080 port is now the problem, i am unable to access even locally.
0 Likes
Highlighted
Absent Member.
Absent Member.

PFA for the attachment.. 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi

What is your jdk version? Webserver version/SM version?

 

I guess you have done "stop -> start" of your Web application server (and SM server), after all these changes you described?

 

If you have configured SSL, check its configuration.

You may also try to recreate the SSL Certificates if any ..

 

Another thing, if your environment is loadbalanced -> there was such an issue before because in sm.cfg the parameter loadBalancer was not correctly spelled. (it was loadbalancer instead of loadBalancer). So you may check that as well.

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks 🙂

View solution in original post

Tags (1)
Highlighted
Absent Member.
Absent Member.
SM Version - 9.3 JDk - 1.6 No there is no load balancer setup in the environment. Yes, SSL has been setup, but how do i check the configuration whether its fine or not?
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

ok, the JDK 1.6 is fine.

What I have noticed in the attached error html file is the following:

 

Error: com.hp.ov.sm.client.common.communications.CommunicationException: javax.xml.soap.SOAPException: Message send failed - connection to host http://ovhrvmsrv.mashreqbank.corp.network:13080/SM/ui refused. Your server session may have been terminated or timed out. You may need to go to the login page and log in once again.

 

Looks like appache is trying to access the SM server via port 13080 instead of 13081. Try to restart the appache server, because it is trying to connect you via 13080 and seems line the change didn't take effect.

-----
If you find this or other posts helpful, please do not forget to click the Kudo Star or to mark it as a Solution if you are the owner of the thread. Thanks 🙂
0 Likes
Highlighted
Fleet Admiral
Fleet Admiral
hi madhu,

you can disable ssl for web client by editing web.xml parameters. or try to connect using debug port go to run command prompt
sm -httpPort:12345 -httpsPort:23456 log:trace.log RTM:3

after this command go to url as:

.../index.do?httpPort=12345

you will get trace.log in run folder

re,
Abhijit K
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi Madhu,

 

we had same issue using SSL and trying to log into web client. We put a ticket in with HP and after 6 phone conferences and numerous emails back and fourth the conclusion was that we needed the latest patch to fix password issues. He sent us the link and we installed the patch and log in and password work fine now. We also had SM9.3 (would have to check version on Monday at work if you need that). Let me know if u need link for patch.

 

HTH,

TODD

Highlighted
Absent Member.
Absent Member.

issue resolved by recreating the certificates.

Thank you all for your replies

0 Likes
Highlighted
Absent Member.
Absent Member.

I am also facing the same error

Error connection to server, Server not up or wrong connection parametrs http://localhost:13080/Sm/Ui(See Attachment)

 

 

My first question is that do i need to install any tomcat or jboss to run the windows client, I have installed IIS 7?

Could you please guide me to resolve this issue i m stuck on this from last couple of days?

 

0 Likes
Highlighted
Absent Member.
Absent Member.
nothing need to install. Reconnect the SM server IP/hostname in you SM client connection if SM server is on remote machine.
You have provided the default "localhost" and work in case of accessing SM from same machine.

hth,
____________________________________
Assign Kudo, if found post useful and mark it accepted if solves the issue.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.