Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..
553 views

created new table didn't appear on the db

Jump to solution

Hi Expert!

I have created new table on "cm3rarea". Its appearing on the dbdict. While I am trying to search through db. I am find the table.

Best Regards,
Tom
0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: created new table didn't appear on the db

Jump to solution

See also Helpserver chapter

System Administration > Database Administration > Data persistence > Database dictionary > Methods for adding database dictionary records > Create an active database dictionary record

Create an active database dictionary record


Applies to User Roles: System Administrator

This procedure assumes the HP Service Manager system has table create-alter-drop-rights to the RDBMS system. If Service Manager does not have table create-alter-drop-rights, your database dictionary record remains inactive and mapped to null tables until you activate it. If your system does not have table create-alter-drop-rights to the RDBMS, HP recommends you enable the option to create DDL to provide to your RDBMS administrator. You can then activate the database dictionary record after your RDBMS administrator has created the tables and columns specified in the DDL.

For Windows clients:

To create an active database dictionary record:
1.Log on to the Service Manager system with a system administrator account.
2.In the System Navigator, click System Definition > Tables.
3.Right-click Tables, and then click New Table.
4.Type the Table name.
5.Add one field for each RDBMS column you want to add.
6.Add a unique key to the database dictionary record.
7.Click OK.

Thank you for using the MicroFocus ServiceManager Support and News Forum. If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

0 Likes
10 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: created new table didn't appear on the db

Jump to solution

Hello,

It will appear there. You were doing it through dbdict? Have you done Alter table?

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: created new table didn't appear on the db

Jump to solution

Yes I created table through dbdict! I have alerted the table also

Best Regards,
Tom
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: created new table didn't appear on the db

Jump to solution

Hello Tom,

 

you need to create a format pointing to that dbdict as well.

I assume the message "Format or file not found" means in your case the format is missing.

I would create two formats: one with name "cm3rarea.g" as detail format and one with name "cm3rarea.qbe.g" as format for listing the records. Filename of format "cm3rarea.g" should be "cm3rarea".

Let me know if that solves the issue.

Heike

Thank you for using the MicroFocus ServiceManager Support and News Forum. If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: created new table didn't appear on the db

Jump to solution

I suppose when you said that it is not present in the DB - you have checked it in the Database via db tools?

As I recall there were cases that it had to run synchonization or something like that to create corresponding table in the db. I would suggest to recheck it in some short time.

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: created new table didn't appear on the db

Jump to solution

Thanks for the reply! Now I am facing one more issue, I am adding the values on the area field only "test1" is getting saved. I have added other values its not getting stored.

Best Regards,
Tom
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: created new table didn't appear on the db

Jump to solution

When I am trying to search, i get only test1 

Best Regards,
Tom
0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: created new table didn't appear on the db

Jump to solution

This is because you have duplicate Keys.

Check what you have set in the DBdict for the unique values in that table.

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: created new table didn't appear on the db

Jump to solution

Hi Tom,

you need to set a key of type "unique" or minimum "no duplicates" on your field to get multiple records stored.

Heike

Thank you for using the MicroFocus ServiceManager Support and News Forum. If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: created new table didn't appear on the db

Jump to solution

See also Helpserver chapter

System Administration > Database Administration > Data persistence > Database dictionary > Methods for adding database dictionary records > Create an active database dictionary record

Create an active database dictionary record


Applies to User Roles: System Administrator

This procedure assumes the HP Service Manager system has table create-alter-drop-rights to the RDBMS system. If Service Manager does not have table create-alter-drop-rights, your database dictionary record remains inactive and mapped to null tables until you activate it. If your system does not have table create-alter-drop-rights to the RDBMS, HP recommends you enable the option to create DDL to provide to your RDBMS administrator. You can then activate the database dictionary record after your RDBMS administrator has created the tables and columns specified in the DDL.

For Windows clients:

To create an active database dictionary record:
1.Log on to the Service Manager system with a system administrator account.
2.In the System Navigator, click System Definition > Tables.
3.Right-click Tables, and then click New Table.
4.Type the Table name.
5.Add one field for each RDBMS column you want to add.
6.Add a unique key to the database dictionary record.
7.Click OK.

Thank you for using the MicroFocus ServiceManager Support and News Forum. If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

View solution in original post

0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: created new table didn't appear on the db

Jump to solution

Thanks! its working prefectly!

Best Regards,
Tom
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.