Highlighted
Valued Contributor.
Valued Contributor.
402 views

crystal reports subreport crashes crystal

We have a report that is nothing but 5 subreports.  It uses the scodbc to connect to SM9.30.  The sureports are:

  • Todays IM's - on Monday include Friday 07:00 thru Monday 07:00.  All others are yesterday 07:00 - today 07:00
  • Yesterdays IM's - the 24 hrs before the above
  • Yesterdays CC's - Monday: Friday 0700 - Monday 07:00 Planned Start; all others yesterday 07:00- today 07:00
  • Todays CC's - Non ECCs with Planned start is today 07:00 to tomorrow 07:00
  • Todays ECC's - Emergency CC's Planned start is today 07:00 to tomorrow 07:00

This was running via Control-M every weekday for years.  in the last few weeks, it's started failing randomly.  In CTM output, the error is:  

Error: Failed to export report: Unknown Database Connector Error

When I try to run the report in Crystal, it just crashes.  The pop up is:  Crystal has stopped working.  Close the Program.

I've gone through each report and I can run each subreport except Yesterdays CC's.

The query on that report is:

if DayOfWeek (CurrentDate) = 2 then     //Monday
{cm3rm1.planned.start}  <=  DateTime (CurrentDate, Time(07,00,00)) and
{cm3rm1.planned.start}  >=  DateTime (CurrentDate -3, Time(07,00,00)) and 
{cm3rm1.category} <> "Production Access" and
{cm3rm1.approval.status} = "approved" and
{cm3rm1.linium.environment} = "production" else

if DayOfWeek (CurrentDate) in [3,4,5,6] then   //Tues-Friday
{cm3rm1.planned.start}  <=  DateTime (CurrentDate, Time(07,00,00)) and
{cm3rm1.planned.start}  >=  DateTime (CurrentDate -1, Time(07,00,00)) and 
{cm3rm1.category} <> "Production Access" and
{cm3rm1.approval.status} = "approved" and
{cm3rm1.linium.environment} = "production"

I've tried removing everything except the planned.start date range, and it still fails.  I made it query for the next three days, and that query works... I get changes planned for the future, but as soon as I update the query for the previous days, the report crashes.

 

Has anyone run into anything like this?  Any ideas on how to correct it?  Like I said, this was working in the past, and now it seems to fail at least once a week.

Thanks.

0 Likes
1 Reply
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: crystal reports subreport crashes crystal

Hello BethQ,
Thanks for your question.

As Crystal Reports runs as an integration to Service Manager, my first suggestion is to check the shared memory, since you are getting connection errors and sudden crashes when using it.

Also, please take on consideration that 9.30 is close to be out of support soon, so I want to encourage you to update to a newer version.

BR!
Jose L. Arias

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution. If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution. If you are satisfied with anyone’s response please remember to give them a LIKE by clicking on the Thumb and show your appreciation.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.