Highlighted
Absent Member.
Absent Member.
1873 views

eventout queue records

Jump to solution

Hello,

 

Again I come to you to resolve an issue that I have with email notifications. I use SMTP to send emails, notifications are generated and sent successfully but the record still in the eventout, when the service restarts are sent back notifications causing confusion and annoyance with users.

 

Scsmtp.ini, sm.ini and sm.cfg files have the keepmail:0 parameter and still remain so in eventOut, I read that when generating the notification and are successfully sent on eventout registration must have the status done or something like that but the state is null.

 

Someone can help me?

Thanks a lot!

 

PS.the scmail.chk file is 0000000000015032

Tags (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Hello to all, and thanks for reply

 

I fix that...

 

in sm.ini i've delete the following lines:
clean:1
keepmail:0
debug:0

 

in scsmtp.ini i've uncommented the following lines:
server:localhost.12690
smtp_reconnect:1
smtp_numberof_retry_connect:10
smtp_reconnect_interval:60
sc_reconnect:1
sc_numberof_retry_connect:10
sc_reconnect_interval:60

 

and start legacy service

View solution in original post

0 Likes
5 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Hi,

 

Can you paste a copy of your scsmtp.ini?  Perhaps in looking at it we may be able to identify why the keepmail:0 parameter is not working, or perhaps things to try.

 

One thing to check is that you don't have debug:1 set in your scsmtp.ini. The debug parameter needs to be set to 0 (debug:0) for keepmail:0 to work.

 

Audrey

0 Likes
Highlighted
Absent Member.
Absent Member.

that's my scsmtp.ini

 

smtpserver:XXX.XXX.XXX.XXX
#server:localhost.12690
smtpport:25
smtpuser:xxx@yyy.com.mx
#smtp_cc:user@company.com
#smtp_bcc:user@company.com
clean:1
#sleep:10
log:scsmtp.log
keepmail:0
debug:0
smtpdebug:1
#smtp_reconnect:1
#smtp_numberof_retry_connect:10
#smtp_reconnect_interval:60
#sc_reconnect:1
#sc_numberof_retry_connect:10
#sc_reconnect_interval:60
#japanese_encoding:jis
#logpreservelen:0
#logmaxlen:5242880

 

sm.ini

 

# ServiceManager Initialization file
# (c) Copyright 2008 Hewlett-Packard Development Company, L.P.
# Configuration Modified Date:9/25/14 5:40 PM
shared_memory:50000000
shared_memory_address:0x50000000
log:../logs/sm.log
system:13080
httpPort:13080
sslConnector:0
httpsPort:13443

sqldictionary:sqlserver
[sqlserver]
sqldb:SM1
sqllogin:user/password
plugin0:kmplugin.dll

groupbindaddress:XXX.XX.X.X
webservices_sessiontimeout:1800
querysecurity:1
queryhashcode:XXX.XX.X.X:13080
smtphost:XXX.XX.X.XXX
smtpport:25
smtpusername:email_user
smtppassword:email_password
mailFrom:xxx@yyy.com.mx
clean:1
keepmail:0
debug:0
smtpTLS:1
sessiontimeout:60
ir_disable:1
msg_buffer_size:30000

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Hi Jhonny,

 

haha this is common issue.

you can create automatic delete eventout in shcedule, so the users canot got back old emails.

-Go to command line and type sch

-create new schedule

-on tab java script you can use my java script code 🙂

functionAutoDelete()

 

{

var evet =newSCFile("eventout");

   ##variable evet merefer ke table eventout

var rc1 =evet.doSelect("evtime<tod()");

   ##select evtime yang kurang dari target time of date.

if(rc1 == RC_SUCCESS)

{

do

{

      evet.doAction("delete");

      #jika status email telah terkirim eventout list akan di delete.

}

while(evet.getNext() == RC_SUCCESS);

}

      else

      print("No records found");

}

AutoDelete(); 

 

you can repeat interval as you want. 🙂

I hope this help!

Please assign Kudos if you get the solution 🙂

 

REgards,

Okik

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Hi,

 

I haven't heard anything about the smtpdebug parameter, but if the debug parameter can be an issue, I would test setting the smtpdebug to smtpdebug:0 also and see if that produces any different behaviour.  I suppose they may be thinking if you are doing debugging then you need the records available to review.  Just a thought.

 

Audrey

0 Likes
Highlighted
Absent Member.
Absent Member.

Hello to all, and thanks for reply

 

I fix that...

 

in sm.ini i've delete the following lines:
clean:1
keepmail:0
debug:0

 

in scsmtp.ini i've uncommented the following lines:
server:localhost.12690
smtp_reconnect:1
smtp_numberof_retry_connect:10
smtp_reconnect_interval:60
sc_reconnect:1
sc_numberof_retry_connect:10
sc_reconnect_interval:60

 

and start legacy service

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.