KaiWinter Valued Contributor.
Valued Contributor.
352 views

mixed mode SM95x and SMA-SM Portal connection

Jump to solution

Hi all,

 

we istalled SMA-SM 2017.11 in the mixed mode with SM 9.52. We use the portal and smart analytics in the docker environment. The connection of SM 9.52 and the portal worked in general but we have one issue:

All the catalogues and items are visible, but you cannot open a ticket or request as the dropdownlists of the request form in the portal are not working (system error).

In the configuration masks is everything green and we do not see any fault... Anybody any idea? We would be thankfull for any helpfull hint!!!

Thanks in advance, Kai

0 Likes
1 Solution

Accepted Solutions
Highlighted
JD_Jinesta Outstanding Contributor.
Outstanding Contributor.

Re: mixed mode SM95x and SMA-SM Portal connection

Jump to solution

Hi Kal,

Two things I want you to check

1- ScriptLibrary record > RestfulQuery around line 195-197, there is a typo error, line looks like >

returCode = restRC['no auth'];

but should be (It's missing an "n")

returnCode = restRC['no auth'];

If you have this problem please fix it.

2- Integration user must have permissions to check data under device table, confirm the user can search device records.

If none of these are problem with your system I suggest to open a support ticket.

Regards,

SM Support Engineer

Thank you for using the Micro Focus Community. If you find that this or any post resolves your issue, please be sure to mark it as an "accept as solution".
0 Likes
2 Replies
Highlighted
JD_Jinesta Outstanding Contributor.
Outstanding Contributor.

Re: mixed mode SM95x and SMA-SM Portal connection

Jump to solution

Hi Kal,

Two things I want you to check

1- ScriptLibrary record > RestfulQuery around line 195-197, there is a typo error, line looks like >

returCode = restRC['no auth'];

but should be (It's missing an "n")

returnCode = restRC['no auth'];

If you have this problem please fix it.

2- Integration user must have permissions to check data under device table, confirm the user can search device records.

If none of these are problem with your system I suggest to open a support ticket.

Regards,

SM Support Engineer

Thank you for using the Micro Focus Community. If you find that this or any post resolves your issue, please be sure to mark it as an "accept as solution".
0 Likes
KaiWinter Valued Contributor.
Valued Contributor.

Re: mixed mode SM95x and SMA-SM Portal connection

Jump to solution

Hi,

 

thanks for your help, unfortunately that didn't work. We found the typo (returCode) in the script and corrected it, and we also checked the rights (our integration user is sysadmin), but that did not help. Find a screenshot of our incident attached. All catalogue items are there, even the user options are shown, but the values of th dropdown fields of the servicedesk interaction ticket can not be diplayed...

Any other idea? Thanks for any input, Kai

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.