ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins. Read more for important details.
ALERT! The community will be read-only starting on April 19, 8am Pacific as the migration begins.Read more for important details.

multiselect.selection("fieldcontents") doesn't work in web-client

Hello colleague!


Do you have some experiance with multiselect.selection("fieldcontents")?


I use it in my custom wizard to get records ids which were selected from a list.

In win-client function works. It returns me ids but in a web-client (ess) the same function in the same wizard returns only NULL.


What did I do wrong? Do I need write something in web.xml?

There is any different way to choose multiple records from list instead of multiselect.selection functions?

7 Replies


I've got some news.


I forget to mention my webtier version. It's 933.


Well a bad part of news is that HP Support confirms that multiselect.selection("fieldcontents") really doesn't work for webtier 933 !!!

But a good is that in webtier 934 this bug was fixed.


Do you know is it possible to use SM 933 with webtier 934?

Absent Member.. Absent Member..
Absent Member..

Yes, 9.34 web tier can be used with all 9.x application releases.


Note that 9.34 introduces a significant change in the appearance of the application (it still works pretty much the same way, though there is a much better date picker, auto-complete is now available, and the messages interface is improved). I wouldn't expect that retraining would be needed, but it will look different. 


If you also upgrade to 9.34 applications, you get access to the new embedded change calendar. It doesn't have the conflict and impact analysis capablities of Release Control, but provides excellent time period management capablities (you can even attach additional approvals based on time period violations).


Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
Absent Member.. Absent Member..
Absent Member..

Hi Experts,


Jane_VK, could you please to show official HP document, where written that multiselect.selection("fieldcontents") is working or should be working in webtier 9.34.


Our webtier version: version 9.34.3000-P3 and SM version:


/opt/HP/ServiceManager9.30/Server/RUN $ ./sm -version
----HP Service Manager Version/Environment Details-----
Executable name: sm
Version: 9.34.3000
Patch Level: P3
System name: 13080
System key: 0x784DFB00
Hardware type: ia64
Network hostname: dn-smdev
Operating system: HP-UX
OS version: B.11.31


and multiselect.selection("fieldcontents") returns null in webclient... so, now  we can say, that this bug is not fixed..


in 9.50 still not working multiselect.selection("fieldcontents")


to workaround this issue:


To work around this issue, use the following rad expression, instead of $L.rm=multiselect.selection("fieldcontents", $L.file).

$"rows");$L.rm={};for $L.x = 1 to lng($ do ($L.void=rtecall("rgoto", $L.rc, $L.filed, $L.x in $ - 1);$L.x in $L.rm=number in $L.filed)

The following information is about how this workaround works:

$"rows")   //This workaround is based on the current situation: The multiselect.selection("fieldcontents") has a defect, multiselect.selection("rows") works fine.
$L.rm={} //initialize $L.rm
for $L.x = 1 to lng($ do ($L.void=rtecall("rgoto", $L.rc, $L.filed, $L.x in $ - 1);$L.x in $L.rm=number in $L.filed) //for each row, insert the number field into $L.rm, if you want to get the content of other field, you should change it accordingly.


Micro Focus Expert
Micro Focus Expert

I found this Defect about multiselect.selection in web-client:

QCCR1E122633 RAD function multiselect.selection("rows") returns the incorrect index in the Web client when using select all

This Defect is solved with
SM9.33P4HF16 Hotfixes are available through Support.
SM9.34P4HF7 Hotfixes are available through Support.

Thank you for using the MicroFocus ServiceManager Support and News Forum. If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.

I encountered a similar problem. Function works for 9.41, but does not work for 9.63-9.64
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.