Highlighted
New Member.
403 views

multiselect.selection("rows") doesn't work properly.

Hi Experts,

I'm facing an issue while using the RAD function multiselect.selection("rows").

 

this is working fine when I select the individual records manually. but I do see an issue when I click on "Select All Check box" on the qbe.

 

$L.info=multiselect.selection("rows");$G.impm={};for $L.x = 1 to lng($L.info) do ($L.void=rtecall("rgoto", $L.rc, $L.filed, $L.x in $L.info - 1);$L.x in $G.imp=number in $L.filed)

 

during the manual selection of records, the value inside of the array $L.info would be {1,2,3,.....)

but when I click on "Select All", $L.info would be {0,1,2,3,.....}

 

 

does any one know how to handle this issue?

 

I'm using 9.31 webclinet.

 

appreciate your help!

 

0 Likes
2 Replies
Highlighted
New Member.

Re: multiselect.selection("rows") doesn't work properly.

is there a way to identify when a "Select All Check Box" is checked?

0 Likes
Highlighted
New Member.

Re: multiselect.selection("rows") doesn't work properly.

I mean is there any RAD function which can tell me when the select all check box is checked?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.