Highlighted
Absent Member.
Absent Member.
1348 views

sm application slow

hai all,

         once i update incident/interaction in the form SD.update.interation and IM.update.incident form and click the save button it will take 40 to 50 second for saving that form.Please any body help me...

 

Regards,

Kavya..

0 Likes
14 Replies
Highlighted
Fleet Admiral Fleet Admiral
Fleet Admiral

Hello,

Do you have any custom background logic (scripts, queries)

which are performed on that actions? System is OOB? How many records are in the system? Do you have integration with other products?

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Is it a new system?

How long has it been running?

Has it been slow since initially configured or has it gradually gotten slower over time?

Are all application actions slow, or just updating an IM?

Is searching, switching queues, intial display of the record also slow?

Is the slow response only affecting some IMs or any IM?

All users, or just a subset of users?

 

What is your SM version (binary and application)?

What RDBMS?

----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
0 Likes
Highlighted
Absent Member.
Absent Member.

Is it a new system?----- no.

How long has it been running?---- more than one year.

Has it been slow since initially configured or has it gradually gotten slower over time?----- past 15 days only it makes problem.

Are all application actions slow, or just updating an IM?---- for only IM and SD updating form.

Is searching, switching queues, intial display of the record also slow?----no, working fine.

All users, or just a subset of users?------all users

What is your SM version? SM 7.11 and database is Oracle 10g.

 

please help me,

kavya...

 

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Kavya,

Did you customized any thing new in your system such as FC,triggers,macros,JS etc.Because all of these types of formatting and calculations will make extra time to process.
However you should check your table size for these modules and can run the RAD trace to check any thing abnormal.


hth,
0 Likes
Highlighted
Absent Member.
Absent Member.

hiii,

     For one month before only i made some changes in the FC--calculation and all but that time also it is working fine,for the past 15 days only it gets showing slow..

 

Regards,

Kavya..

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Kavya,

You should check the RAD trace and add the RTM and debugquery parameters to sm.ini file , this will provide you the time taken at each stage of processing the record.


hth,
0 Likes
Highlighted
Absent Member.
Absent Member.

Dear pikutj,

                 Thanks for your valuable reply. One more thing what are the parameter i added in the sm.ini file, because i am new to SM.

 

Regds,

Kavya.

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi ,

from help server -----
Parameter: rtm

Startup parameters change the behavior of the HP Service Manager server. You can always set a startup parameter from the server's OS command prompt.

Parameter
rtm
Description

This parameter causes the Service Manager server to write Response Time Monitor (RTM) performance statistics to the log file.
Valid if set from
server's OS command prompt
Initialization file (sm.ini)
Requires restart of Service Manager server?
No
Default value
None
Possible values
Logging level

2 (Displays the response and transaction times)
3 (Displays the information from rtm:2 and also provides a panel by panel trace of the RAD application)
4 (Displays the information from rtm:2 and rtm:3 and also provides details about the usage of each RAD operator and command panel for the transaction)
5 (Displays the same information as rtm:4)

Example usage
Initialization file: rtm:2


But it would need restart of application services.
After adding this reproduce the issue and look for sm.log file.


hth,
0 Likes
Highlighted
Absent Member.
Absent Member.

Hai pi kutj,

                 I added those fields in sm.ini file and do the same.I attached the sm.log files after updating an incident do the needful for me.

regards,

kavya..

 

0 Likes
Highlighted
Fleet Admiral
Fleet Admiral

Goto operator and find Incident profile and goto Incident profile->Incident matching options tab and check whether all checkboxes are enabled or disabled. Reverse them and check.

 

Another possiblitiy is check whether "ir_disable" or "ir_asynchronous" parameter is defined and enabled in sm.ini file

0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Kavya,

Check your schedule file.From your log file It seems that it is taking too much time for updating schedule file. If it have more than around 30 records than would be cause of issue.
4004( 3552) 07/18/2011 16:53:57 JRTE I SequenceNumber Task for schedule is completed in 4687 milliseconds.
4004( 3552) 07/18/2011 16:53:57 RTE D (0x0166D5B8) DBACCESS - Insert against file schedule in 4.719000 seconds (schedule.id=3182565)

Delete your sm.log file and then restart the SM services and then reproduce the issue only once and take backup of log file ,then go through it and check for all transactions which are taking more than couple of millisecond using following type of lines :
4004( 3552) 07/18/2011 16:53:57 RTE D (0x01656EE0) DBACCESS - Find against file scmessage in 0.000000 seconds


hth,
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.