New Ranks & Badges For The Community!
Notice something different? The ranks and associated badges have gone "Star Fleet". See what they all mean HERE
Highlighted
Absent Member.. Absent Member..
Absent Member..
952 views

system_unload does not create a file

Jump to solution

On SM7.11.  I'm in the ../RUN directory of our Linux system, permissions on the /RUN dir are open, 777, and as a test, I did a 'touch' of a file, just to see if I had mod privileges. The problem is: when I do ./sm  -system_unload

nothing is created. no *.unl file, no system_unload file, nothing.

What should I check to get the unload to function properly?

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.. Absent Member..
Absent Member..
there were two factors that lead to this issue. 1) unbeknownst to me, there was a symbolic link to the system.unload file, so the actual file was being written in a different file system.
And 2) the unload filled the file system and brought the system to its knees.
Anyway, the issue has now been resolved.

View solution in original post

0 Likes
3 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..
System Unload should create a new system.unload directory with all the .unl files inside it. There cannot be an existing system.unload directory or it will not work.
----------------------------------------------------
Kudos - what, where, how, and why
Want Good Answers? Ask Good Questions...
Highlighted
Absent Member.. Absent Member..
Absent Member..

Hi there,

 

What exact command are you using? I have not found a word about system_directory parameter. So you should try something like this:

 

./sm -system_unload -system_directory:/tmp/sm_unl/

Regards.
Highlighted
Absent Member.. Absent Member..
Absent Member..
there were two factors that lead to this issue. 1) unbeknownst to me, there was a symbolic link to the system.unload file, so the actual file was being written in a different file system.
And 2) the unload filled the file system and brought the system to its knees.
Anyway, the issue has now been resolved.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.