Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE

How do I connect SilkCentral Test Manager to my database when using SQL Server Express Edition?

How do I connect SilkCentral Test Manager to my database when using SQL Server Express Edition?

Problem:

How do I connect SilkCentral Test Manager to my database when using SQL Server Express Edition?

Resolution:

When attempting to connect SilkCentral Test Manager to your database when using SQL Server Express Edition you may get the following error: "Host "" not found"

Host not found

This error message is produced if you do not have TCP/IP connections enabled in SQL Server. SilkCentral Test Manager uses TCP/IP to connect to the SQL Server database,but SQL Server Express Edition does not enable TCP support by default.

To enable TCP/IP connections:

1. On the machinewith SQL Express installed, open the SQL Server Configuration Manager.

2. Expand the SQLServer 2005 Network Configuration node on the left.

3. Select theProtocols for SQLEXPRESS node on the left.

SQLEXPRESS protocols

4. Right-clickthe TCP/IP item on the right and select Properties.

5. On the Protocol tab, change Enabled to Yes.

protocol

6. On the IPAddresses tab, under the IPAll node clear the TCP Dynamic Ports field. Also enter the port to listen on inthe TCP Port field. For example, 1450. Remember this port, because it needs tobe used in the SCTM connection string.

IP Addresses

7. On the OKbutton to save the changes.

8. Restart theMicrosoft SQL Server Express service using either the standard service control panel or the SQL Expresstools.

Before you can connect the database to SilkCentral Test Manager you also need to enable SQL Server authentication. To do this:

1. On the machinewith SQL Express installed, open the SQL Server Management Studio Express tool.

2. Right-clickthe instance of SQL Express to configure, and select Properties.

3. Select theSecurity section on the left.

4. Change theServer Authentication to SQL Server and Windows Authentication mode.

authentication

5. Restart theMicrosoft SQL Server Express service using either the standard service control panel or the SQLExpress tools.

Now you should be able to connect successfully to the database through the Administration - System module in SilkCentral Test Manager.

connected database

If you look in your database now using the SQL Server Management Studio tool you can see the database has been created.

Note: If you recieve a "no login for user "sa"" error message when connecting to the database, you will have to reset the "sa" password and set its Login status to "Enabled". This is normal on a fresh install of SQL Server. Please make these changes in SQL Server Managerment Studio.

1) Connect under "Windows Authentication"

2) Expand Security -> Login, here you will see the "sa" username

3) Right-click "sa" and select properties to go to the Login Properties page

4) Under General, select option "SQL Server Authentication" and enter new password (default "sa")

5) Under Login Status, select Login "enabled".

6) Press Ok to save changes.

database created



Old KB# 25033

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2013-02-15 19:51
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.