Created On:  24 October 2011

Problem:

I have successfully uploaded my Agent Cluster xml file into SilkCentral Test Manager



But when I connect to SilkCentral Test Manager from SilkPerformer, the ‘Test Manager agent cluster:’ listbox is empty?

Resolution:

This issue indicates that the Agent Cluster xml file is not in the correct format. If you created the xml file manually please ensure it matches the format below (and attached). If you exported the original xml from SilkPerformer using the ‘Export Agent Pool’ functionality you need to make amendments. The contents of an exported agent-pool file and the agent-clusters file are nearly identical, so this typically only involves enclosing the elements of the exported agent-pool file within a element.

This agent-clusters file includes a SctmAgentClusters root element. Within the root element are AgentPool elements, one for each agent pool in the cluster. Within each AgentPool element are Agent elements that convey the connection properties, capabilities, and system information of the individual agents.



 
 
    19200
    19201
    192.168.1.100
    5
    false
   
   
   
   
   
   
   
   
   
   
    7803300
    7.8.0.3332
    2039 MB
   
    1
    3200 MHz
   
    5.0
    WinNT
 
 
   
    19200
    19201
    false
    :8080
    192.168.1.101
    5
    :1080
    false
    false
    false
   
   
   
   
   
   
   
   
   
   
    7803300
    7.8.0.3343
    1983 MB
    Intel Pentium IV
    2
    3200 MHz
    Service Pack 2
    5.2
    WinNT