Lieutenant
Lieutenant
490 views

HTTP Error 413.1 - Request Entity Too Large

Hi
As part of the requirement, I had to use apache poi to read data from excel spreadsheet. This needed xmlbeans.jar to be used that is huge in size. As a result when am trying to upload the library, I do get Error Summary
HTTP Error 413.1 - Request Entity Too Large.
Could you please let me know my options. I can exclude the jar file from build.xml but is there a way for silk central to be able to access it from the execution server file location eg c:\sharedlibs
I am using Silk Central 16.5 and read that in Silk Central 20.5 there is an option increase the size of client_max_body_size property.

0 Likes
6 Replies
Micro Focus Expert
Micro Focus Expert

Hi @rekhasunkara1,

 

I assume you are trying to execute an automated test from Silk Central.

When does the error happen? On fetching source control to the Execution Server? Or on uploading result files back to the AppServer?

 

What type of test are you executing? If it is a Junit then you could remove the library from the source control and add it to the classpath of the test with an absolute path in this form c:\shardlibs\xmlbeans.jar.

 

Any chances to upgrade to a more recent version of Silk Central?

 

Regards,

Hubert

 

0 Likes
Lieutenant
Lieutenant

Greetings Hubert

Error happens when I am trying to manually upload a library.zip (generated  by SILK4J). Its a keyword driven type test.

We do have plans to upgrade silk central to 20.5 but will take some more time. Right now we are in process of upgrading silk test from 18.5 to 20.5. Hopefully silktest 20.5 is compatible with Silk central 16.5 with no issues.

0 Likes
Micro Focus Expert
Micro Focus Expert

Hi @rekhasunkara1,

 

How large is your library.zip?

 

I just tried to upload a library.zip with a size greater than 110 MB. This worked fine.

 

Do you use Silk Central with IIS or some proxy? Maybe you have a limit configured there.

Did you modify the configuration?

 

Regards,

Hubert

 

0 Likes
Lieutenant
Lieutenant

Hi Hubert

Somehow I missed your reply. Larger size of library file is due to apache POI as dependency. We did a workaround not to use apache POI.

 

Do you use Silk Central with IIS or some proxy? - Its on IIS

Maybe you have a limit configured there. - Can you please point me to a place where , If possible, I can increase the limit.

Did you modify the configuration? - Not in the recent past.

 

Besides the above, I updated Silk Test on execution server to 20.5 while Silk Central is still at 16.5. When I ran  my test, I get the below error message. Is it because of the compatibility issue? Is there a workaround to fix this without upgrading the Silk Central?

java.lang.NoClassDefFoundError: com/borland/silktest/jtf/Desktop

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Hi @rekhasunkara1,

 

In IIS Manager select your site (e.g. "Default Web Site"). Go to Request Filtering > Edit Feature Settings…

In the dialog you can set Maximum allowed content length.

 

Regarding the issue with Silk Test 20.5 and Silk Central 16.5 I fear that this is a compatibility issue and you have to upgrade Silk Central to the same version as Silk Test.

 

Regards,

Hubert

 

0 Likes
Lieutenant
Lieutenant

Thank you Hubert

Upgrading silk central 16.5 is in my list  but I fear of losing all the work done so far incase of any issues. Do we have any step by step instructions on how to upgrade silk central from one version to another version?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.