Absent Member.
Absent Member.
520 views

Report subscription - timing issue?

Hi ,

 

We have configured several execution plans to trigger an email subscription at the end of the execution and it works , but not completely.

The attached pdf document is not complete (content-wise) - loading spinners , empty fields , no statistics and charts (or half -loaded)...

Is there a solution or workaround for the issue we have?

 

Thank you in advance.

 

BR,

Boris,

Tags (2)
0 Likes
2 Replies
Micro Focus Expert
Micro Focus Expert

Hi Boris,

Could you please open a support ticket for this issue? Please attach the report definition as well as the incomplete pdf.

Regards,
Hubert
0 Likes
Absent Member.
Absent Member.

Hi Hubert,

Thanks for the response, I will talk to my colleagues and create a support ticket for this issue.

I'm not sure whether sharing the report definition would help - the linked  databases most likely are not accessible for MF , at the same time they contain some sensible information (URLs to databases , credentials..) - let's see..

I did some additional tests and seems like the issue doesn't have to do anything with the email subscription.

Even clicking on the "View report as PDF" leads to an incomplete PDF - missing icon and a loading spinner bar is seen on the first page. As a web page everything looks perfect - so , here some assumptions:

- "View report as PDF" triggers a new report generation (like clicking on the button "Update")

- PDF generation/export "starts" before the page is fully loaded ?!?

 

Some additional details:

- the report contains images , loaded from another server (outside of SILK databases) and they are present/available (and complete) in the PDF.

- the pics are loaded at their full size (for example 1080x1920) in the PDF , which of course, doesn't look nice in the PDF (including aligment issues , only a portion of them is visible to the reader of the report, etc.) and the size of the report gets huge really easy - as aside problem : email limit of 8 MBs is reached and the subscription refuses to send the PDF report...

 

I will try to summarize in a few follow-up questions:

- When, at which point of time, the PDF generation/export starts? On which event: onPageLoaded()...?

- If the issue is in the report definitions we have (even though , the web pages look perfect) , where to look at ?

- Can we somehow configure the PDF export: scale the images into a thumbnails , for example? "Microsoft print to PDF" feature generates a PDF where the pics are with the exact same size as they appear on the web page - is there a similar setting for the SCTM PDF generation?

 

Looking forward for your feedback.

Thank you in advance.

 

BR,

Boris,

 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.