Highlighted
ddang Regular Contributor.
Regular Contributor.
283 views

output.xml run comment

Hello,

Does anyone know if it is possible to pass through a run comment in the output.xml that gets uploaded when running an automated test.

Below is my current sample output.xml (which uploads the test result and message appropriately)

<?xml version="1.0" ?>
<ResultElement TestItem="Automation Test">
<ErrorCount>1</ErrorCount>
<WarningCount>0</WarningCount>
<WasSuccess>false</WasSuccess>
<Incident>
<Message>Analytics Failed, see log</Message>
<Severity>Error</Severity>
<Detail>
<TestName>Automation Test</TestName>
<Info>See attached screenshot</Info>
</Detail>
</Incident>
</ResultElement>

I'd like to be able to push a message that will display in the run comment field of the test run.

0 Likes
7 Replies
Micro Focus Expert
Micro Focus Expert

Re: output.xml run comment

Hi ddang,

 

It is not possible to add a message to output.xml that is used as a run comment. The run comment field was introduced to manually add a comment to a run, e.g. to describe why a certain run was not finished as expected.

 

Regards,

Hubert

0 Likes
ddang Regular Contributor.
Regular Contributor.

Re: output.xml run comment

Thanks for the reply @Hubert Inreiter .

Is it possible then to somehow set error messages in the Run Errors report under the Execution reporting folder? I notice this report only shows a count of errors but the description implies an Error message associated to why the run failed is also in there.

However it seems when we go to the Report tab nothing is loaded (I can confirm there is data returned in the Data tab).

I have not modified the query as it's the default one from global reports. I've attached a screenshot to confirm the report I am attempting to use.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: output.xml run comment

Hi @ddang,

 

What do you mean by "when we go to the Report tab nothing is loaded"? It should look like this:RunErrrorsExample.PNG

 

Can you confirm your ChartServer is working?

 

Regards,

Hubert

 

0 Likes
ddang Regular Contributor.
Regular Contributor.

Re: output.xml run comment

Hi @Hubert Inreiter 

I've attached the Report tab which shows nothing. I confirmed the data tab has data rows of test failures returned.

The test type we're using is Process Executor and we're only uploading an output.xml (no JUnit specific result file)

 

 

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: output.xml run comment

Hi @ddang,

 

It seems your ChartServer cannot access the Silk Central frontend properly. I'd suggest opening an support case to fix the ChartServer configuration and proceed with the report debugging.

 

Regards,

Hubert

0 Likes
ddang Regular Contributor.
Regular Contributor.

Re: output.xml run comment

Hi @Hubert Inreiter 

I've attached a screenshot of our SilkCentral admin page. This should mean SilkCentral is able to talk to the Chart servers right?

Or is there another way for me to check this.

Thanks,

David

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: output.xml run comment

Hi @ddang,

 

Click on the edit action of your chart server. In the dialog click on the "Check" button. If everything is ok you will see a chart in the following dialog.

 

Do you need two chart servers? I would recommend to focus on one and to set the other "inactive".

 

Regards,

Hubert

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.