Currently there is no support for 64 bit versions of the Java Development Kit.  As Silk Performer is a 32 bit application it cannot load a 64 bit module into its process space.  Attempting to use a 64 bit JDK will result in an error stating "Can't start JVM v1.2...".  

The Java version installed can be determined by running the following command at the command line:

java -version

The output will look like this:

java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)