Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE

What can cause page timers to be larger than the transaction times or duration?

What can cause page timers to be larger than the transaction times or duration?

This issue occurs when Silk Performer is configured to use High Resolution Timers on a machine were the CPU which uses "Speed Stepping".

If it is not possible to disable speed stepping on the processor then turn off "High resolution timers" in Silk Performer by doing the following;
SETTINGS | ACTIVE PROFILES | REPLAY | RESULTS | TRUELOG Tab | Un-check "High resolution timers for page statistics"

Alternatively, add the following line to your script.

WebSetOption(WEB_OPT_HIGH_RES, 0);

This will disable the use of high resolution timers.

A re-run of the script should display the correct page times.

This issue will be addressed in a future version of Silk Performer were the use of stepping will be automatically detected.

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2013-02-15 18:43
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.