alexmelo Absent Member.
Absent Member.
1027 views

JMX Monitoring in Silk Performer 17.5

Jump to solution

Hi all,

I'm trying to monitor JVM, but i'm taking error with a message "Unable to create Java VM", someone could help me about it? 

i'm using java 32bit. i've already ruined "perfJVMPlaceholder.exe" and i still take the same error.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: JMX Monitoring in Silk Performer 17.5

Jump to solution
Hi there.

Check that you have specified a valid 'Java home' path in Settings | Active Profile | Java | General within Silk Performer Workbench.

Once you have valid path, click on the Advanced tab and click the 'Check JVM' button.

Does that help?
0 Likes
6 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

RE: JMX Monitoring in Silk Performer 17.5

Jump to solution
Hi there.

Check that you have specified a valid 'Java home' path in Settings | Active Profile | Java | General within Silk Performer Workbench.

Once you have valid path, click on the Advanced tab and click the 'Check JVM' button.

Does that help?
0 Likes
alexmelo Absent Member.
Absent Member.

RE: JMX Monitoring in Silk Performer 17.5

Jump to solution
Thanks for your answer, but i've done this too.
0 Likes
Micro Focus Expert
Micro Focus Expert

RE: JMX Monitoring in Silk Performer 17.5

Jump to solution
At which point exactly is the error happening and which java exactly are you trying to monitor?

Is there a java home path set when you click on the 'Server Configuration...' button of the Data Source Wizard screen?
0 Likes
alexmelo Absent Member.
Absent Member.

RE: JMX Monitoring in Silk Performer 17.5

Jump to solution
Yes, It's exactly that situation. 'Server Configuration' button show up for me disabled.
0 Likes
Micro Focus Expert
Micro Focus Expert

RE: JMX Monitoring in Silk Performer 17.5

Jump to solution
Hi,
You can view the following files to check if the correct java paths have been configured for your system:

C:\Program Files (x86)\silk\Silk Performer 17.5\Include\jmx-config\jmx-config.xml
C:\ProgramData\Silk\Silk Performer 17.5\perfExpJVM.xml
C:\ProgramData\Silk\Silk Performer 17.5\perfJvm.xml

If not, the simplest solution may be to reinstall Silk Performer so that the installed JVMs are detected and these config files are updated.

Or you could try closing Silk Performer and run the perfJVMPlaceholder.exe using the following syntax:

"C:\Program Files (x86)\Silk\Silk Performer 17.5\perfJVMPlaceholder.exe" "C:\ProgramData\Silk\Silk Performer 17.5\*.xml" "C:\Program Files (x86)\Silk\Silk Performer 17.5\Include\jmx-config\*.xml"

-Neil
0 Likes
alexmelo Absent Member.
Absent Member.

RE: JMX Monitoring in Silk Performer 17.5

Jump to solution
It's works, thanks!!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.