Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
droman Absent Member.
Absent Member.
4334 views

"Silkperformer could not find a merged .tsd file"

Jump to solution

Can someone please explain why I may all of the sudden be receiving this issue while running tests after well over a year of successful test runs?  I just ran a test for an hour and ended up with no results because of this issue.  Time Series Data is checked in the General tab in my profile under "Results".  

Can someone please advise?  I found one article while searching for Google but the answer did not help.  I am running SilkPerformer 15.5.

Just to add to this I also see an error stating, "<agent name> - SYSTEM: 18 - There are no more files"

Tags (2)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

RE: "Silkperformer could not find a merged .tsd file"

Jump to solution

Via a support case we found the problem was actually related to a setting in System | Results.

View solution in original post

0 Likes
5 Replies
LeeanneQ Absent Member.
Absent Member.

RE: "Silkperformer could not find a merged .tsd file"

Jump to solution

Hi,

One of the common reason for this is firewall restrictions.  Please ensure that the necessary ports have been opened for communication between the Controller and Agent machines.  The following ports need to be opened in the firewall: Ports 19200, 19202 and 19203, or 19201, 19202 and 19203 if secure connection.

In one instance reported this was simply because a laptop was being used and Wireless was enabled (creating additional security).  Turning off Wifi resolved the issue.

The System 18 error you mentioned is most commonly related to user account permissions.  Please see the following article:

SYSTEM 18 - There are no more files

community.microfocus.com/.../21950.system-18-there-are-no-more-files.aspx

Best Regards

Leeanne

0 Likes
droman Absent Member.
Absent Member.

RE: "Silkperformer could not find a merged .tsd file"

Jump to solution

LeeanneQ,

Thank you for your response.  I do not have the administrative rights to open ports in the firewall unfortunately so I will have to depend on my company's support team.  That said, I tried something different.  I went under System Settings -> Agents -> Advanced Tab and placed a check mark next to "Use particular user account".  I entered my domain credentials and saved the changes.  I executed a brief 5 user test to run for ten minutes to ensure everything is working as expected.  The test executed and produced the results in the environment I was hoping for however I am still receiving that merged .tsd file error and I am unable to see any performance results.  If you or anyone can help me get to the bottom of this I would greatly appreciate it.

0 Likes
LeeanneQ Absent Member.
Absent Member.

RE: "Silkperformer could not find a merged .tsd file"

Jump to solution

Hi,

If the correct ports are not opened for communication between the Controller and the agent, the files will not be able to be transferred between the machines which would cause the issue you’re seeing.  Please work with your support team to have them open the required ports which will help with this.    

In the meantime the files may still exist on the agent machine and you could copy the to the controller and merge them using the wizard in Performance Explorer.

Best Regards

Leeanne

0 Likes
Micro Focus Expert
Micro Focus Expert

RE: "Silkperformer could not find a merged .tsd file"

Jump to solution

Via a support case we found the problem was actually related to a setting in System | Results.

View solution in original post

0 Likes
droman Absent Member.
Absent Member.

RE: "Silkperformer could not find a merged .tsd file"

Jump to solution

It would not surprise me if the support case you are referring to was the phone call I made yesterday.  For anyone else doing a google search or searching this great forum for an answer to this issue please make sure you check that "Merge time series data on agents" is checked.  This check box can be found under Settings -> System -> Workbench -> Results tab.  

I have no idea how this got unchecked for me as this is a tab I have never clicked on.  However, the support specialist was very helpful on the phone.  Thank you all again for taking the time to respond.  It is much appreciated.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.