Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE

Why won"t SilkTest write any Registry keys on Vista32? I have UAC turned off.

Why won"t SilkTest write any Registry keys on Vista32? I have UAC turned off.

If you get an error message similar to this in your results:

[ ] *** Error: Registry entry "" not found
[ ] Occurred in SYS_SetRegistryValue
[ ] Called from Reg_CreateValue at Registry.inc(161)

and you are certain you have User Access Control turned off, please check your script and/or Runtime | Options to see if the agent option OPT_USE_ANSICALL is set to TRUE. If it is, set it to FALSE in the script just before writing the Registry key (Agent.SetOption(OPT_USE_ANSICALL,FALSE)), then set it to TRUE again (Agent.SetOption(OPT_USE_ANSICALL,TRUE)) after the write is complete and this part of the test will complete correctly.

There is a bug with OPT_USE_ANSICALL in all versions of SilkTest that support Vista32 from SilkTest2006 R2 SP1 backwards that causes Registry writes to fail.

Old KB# 20742

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2013-02-15 19:13
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.