nick_hendricks Absent Member.
Absent Member.
583 views

Error while running test in Silk Workbench

Error while running test in Silk Workbench


Hi all! Am experiencing an error on a SilkTest client while playing back a script recorded in Silk Test Workbench (version 18.0). As playback progresses, I am getting an error with the following text:

"Unexpected Error Occured:

Message = Communication link failure

Trapped at location, File: CTPSvcDB.cpp, line 3808

CException Runtime Class=CDBException Code: -1, State:08S01, Native:0, Origin:[Microsoft][SQL Server Native Client 10.0]"

Doing a bit of research, and my DBA is seeing what looks like dropped connections from the SilkTest database (not the license meter or anything). 

I also appear to be getting SilkTest application errors - truthfully, am not sure if this is the appropriate log to be looking through, but in my OpenAgent log on the client, I have what appera to be errors on the Spy Hierarchy Manager thread stating connections are being dropped.

This error is occurring intermittently, but on several client instances of SilkTest. CDBException state 08S01 might imply a network issue, and that may be the case here... but am curious if anyone recognizes this as a problem with the application itself or it's database.

This is an enterprise setting over which I don't have complete control, so I haven't finished tracking down all the environmental factors (desktop updates that are changing something about the ODBC config, or administrative changes to the SilkTest database) but assuming for a moment that nothing has changed, does this errant behavior sound familiar to anyone? Will probably open a support case for this directly w/ Microfocus, but just wanted to see if it rings any bells with anyone in the community.

Thanks in advance folks! Happy testing.

0 Likes
2 Replies
Highlighted
Micro Focus Contributor
Micro Focus Contributor

RE: Error while running test in Silk Workbench

Hi Nick,

Thank you for posting on the Silk Test community page. I have reviewed some previous Silk Test issues but this has not been reported before. If you are still experiencing the issue I would advise opening a dedicated support incident.

If you choose to log the incident please provide details of the environment where Silk Test and the database resides in addition to the versions of Silk Test and SQL Server being used.

Many thanks,

Chris
0 Likes
LauNataly
New Member.

Re: Error while running test in Silk Workbench

I have the same error.

I can't modify any asset visual test or .NETScript 😞

 

Error : 0x8000ffff

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.