Our vBulletin migration is complete.
Welcome vBulletin users! All content and user information from the Micro Focus Forums (vBulletin) site has been migrated to this site. READ MORE.
Honored Contributor.. connection Honored Contributor..
Honored Contributor..
154 views

E-mail not working in Sitescope

Hi Team,

 

Sitescope is not sending alerts and the below is the screenshot and it was working fine before.

We have tried test connection with both SSL and with SSL but it is not sucessful, worked with Exchange team and the account configured is correct, the same account is working fine with NNM means we get alerts from NNM and not from sitescope.

 

Please suggest.

 

site.jpgsite1.jpg

0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

Re: E-mail not working in Sitescope

Hi connection,

is the error you provided a screenshot from going to
  SiteScope -> Preferences -> Email Preferences
and clicking on "Test Email Recipient"?

  The error was:
   java.net.ProtocolException: 504 5.7.4 Unrecognized authentication type
 
When I run this test with my usual configuration
(just specified the Email server domain name, Admin email, From email, all others default)
the protocol shows:

Mail Test Completed! The test message was sent to whomever@microfocus.com
 --> connecting to smtp.swinfra.net:25, timeout=60000
 <-- 220 localhost ESMTP
 --> HELO sov02bac19.swinfra.net
 <-- 250 localhost
 --> MAIL FROM:<SIS_sov02bac19@hpe.com>

When I also specify a Login and Password (like you did as per your screenshot),
the protocol shows:

Mail Test Completed! The test message was sent to whomever@microfocus.com 
 --> connecting to smtp.swinfra.net:25, timeout=60000
 <-- 220 localhost ESMTP
 --> EHLO sov02bac19.swinfra.net
 <-- 250-localhost
 <-- 250-PIPELINING
 <-- 250-SIZE
 <-- 250-ETRN
 <-- 250-ENHANCEDSTATUSCODES
 <-- 250-8BITMIME
 <-- 250-DSN
 <-- 250 SMTPUTF8
 --> MAIL FROM:<SIS_sov02bac19@hpe.com>
 ..
 
The difference is that we use the HELP command when no user and password is being used, and the ELHO command if a user and password has been provided.
 
For troubleshooting you might wanna run
from the SiteScope server
  telnet <smtp_server_name> 25
   this should return something like
     220 localhost ESMTP
   then enter
     helo <SiteScope_server_hostname>
   this should return something like
     250 localhost
 
   OR
     ehlo <SiteScope_server_hostname>
   which is supposed to return a list of settings:
     250-localhost
     250-PIPELINING
     250-SIZE
     250-ETRN
     250-ENHANCEDSTATUSCODES
     250-8BITMIME
     250-DSN
     250 SMTPUTF8
   
 depending on the eMail server you now can enter HELP to get a lost of commands (this doesn't work on the email server I'm using):
 
   HELP
     214-This server supports the following commands:
     214 HELO EHLO STARTTLS RCPT DATA RSET MAIL QUIT HELP AUTH BDAT

My best guess is that your email server has been configured NOT to allow ELHO command for whatever reason.

You might wanna check the links
  http://www.chilkatforum.com/questions/5071/smtp-504-574-unrecognized-authentication-type-error-with-smtpoffice365com
  http://www.samlogic.net/articles/smtp-commands-reference.htm
but there are many others on error 5.7.4, which BTW is NOT a SiteScope issue, it's an issue with your SMTP server 😉

I also found one case with the solution
..
the customer needed to configure the SMTP server with his credential in order to be able to add an email for the email alert
..

Greetings
Siggi

Customer Support
Micro Focus

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Honored Contributor.. connection Honored Contributor..
Honored Contributor..

Re: E-mail not working in Sitescope

Hi 

Commands all successful Sitescope server can communicate with SMTP from CMD but when we test E-mail prefference its gives the same issue.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: E-mail not working in Sitescope

Then you might need to check with your mail server admin to for example trace what's going on on the mail server end.

Greetings
Siggi

Customer Support
Micro Focus

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.