Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Absent Member.. mkba Absent Member..
Absent Member..
819 views

SiteScope URL Monitor- content match error

Jump to solution

Hi,

I would like to ask for an assistance with regards to the issue I'm encountering in SiteScope URL monitor. Below is the configuration of the said monitor:

URL: http://bdc-resschp01.na.pg.com

Content match: /This is a private Computer/

When I'm trying to run the monitor, I keep getting a content match error even though the text "This is a private Computer" is found on the site. I've tried to run the tool in SiteScope and below is the result that I've got:

==================================================

SITESCOPE HTTP REQUEST HTTP REQUEST HTTP REQUEST HTTP REQUEST HTTP REQUEST HTTP REQUEST

GET / HTTP/1.1

User-Agent: Mozilla/4.0 (compatible; MSIE 4.01; Windows NT)

Pragma: No-Cache

Accept: */*

Host: bdc-resschp01.na.pg.com

SITESCOPE                                         BLANK LINE

SITESCOPE HTTP RESPONSE HEADERS

HTTP/1.1 200 OK

Content-Length: 660

Content-Type: text/html

Content-Location: http://bdc-resschp01.na.pg.com/iisstart.htm

Last-Modified: Wed, 26 Oct 2011 15:20:09 GMT

Accept-Ranges: bytes

ETag: "701ae0bff293cc1:2bbb"

Server: Microsoft-IIS/6.0

X-Powered-By: ASP.NET

Date: Wed, 25 Nov 2015 17:27:29 GMT

SITESCOPE HTTP RESPONSE BODY

 

<html>

 

<head>

<meta HTTP-EQUIV="Content-Type" Content="text/html; charset=Windows-1252">

 

 

<title ID=titletext>Keepalive Page</title>

</head>

 

<body bgcolor=white>

<table>

<tr>

<td ID=tableProps width=70 valign=top align=center>

<img ID=pagerrorImg src="pagerror.gif" width=36 height=48>

<td ID=tablePropsWidth width=400>

 

<h1 ID=errortype style="font:14pt/16pt verdana; color:#4e4e4e">

<P ID=Comment1><!--Problem--><P ID="errorText">Keepalive Page</h1>

 

<P ID=Comment2><!--Probable causes:<--><P ID="errordesc"><font style="font:9pt/12pt verdana; color:black">

Keepalive Page for Monitoring

 

</td>

</tr>

</table>

 

</body>

</html>

==================================================

What I did noticed from the result is that SiteScope still sees the old content of the URL which has the Keepalive text. But when I try to manually access the URL via browser, I'm getting the new content of the site. Please advise. Thanks in advance.

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

Re: SiteScope URL Monitor- content match error

Jump to solution

So what may happen if you tick the below option if you have not tested it yet? Is it still going to Keepalive page?
[v] Use WinInet

With this option, URL monitor will use WinInet Windows OS library, just similar to many web browsers for Windows platform. However if this alone looks still not helping, perhaps you may next want to check with IIS admin to understand why SiteScope is getting the different page in your environment as per your observation?

Regards,

0 Likes
4 Replies
Hgutierrez Absent Member.
Absent Member.

Re: SiteScope URL Monitor- content match error

Jump to solution

set threshold ?

Content match OK : /This is a private Computer/

Error: status =! 200 ?

OK:  Status ==200?

0 Likes
Absent Member.. mkba Absent Member..
Absent Member..

Re: SiteScope URL Monitor- content match error

Jump to solution

Yes, that is the set threshold for this monitor.

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: SiteScope URL Monitor- content match error

Jump to solution

So what may happen if you tick the below option if you have not tested it yet? Is it still going to Keepalive page?
[v] Use WinInet

With this option, URL monitor will use WinInet Windows OS library, just similar to many web browsers for Windows platform. However if this alone looks still not helping, perhaps you may next want to check with IIS admin to understand why SiteScope is getting the different page in your environment as per your observation?

Regards,

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: SiteScope URL Monitor- content match error

Jump to solution

Hi mkba,

you might need to modify the monitor configuration and add to the field
HTTP Settings -> Request headers :

the option
  Cache control: no-cache

Cache control: no-cache is generally used in a request header (sent from web browser to server) to force validation of the resource in the intermediate proxies. If the client doesn't send this request to the server, intermediate proxies will return a copy of the content if it is fresh (has not expired according to Expire or max-age fields). Cache-Control reinforces these proxies to validate the copy even if it is fresh.

With this SiS should always get a current version of the web page.

Greetings
Siggi

Customer Support
Micro Focus

If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.