Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
djsubit Absent Member.
Absent Member.
227 views

Sitescope failing to send <mainParameters> to remote script

Jump to solution

I have a script that exists on a remote server that is executed via sitescope script alert. The script picks up the default 6 parameters without issue when it executes. However, when I configure the script alert to send over the <mainParameters> parameter it times out. I have tried setting the timeout value to 5 minutes and it still times out. My hunch is that mainParameters contains too much information and Sitescope isn't configured to send that much information over the wire. I have another script alert that runs a script locally on the sitescope server itself and uses mainParameters without issue.

Anyone know of why my script alert would time out when trying to use mainParameters on a remote script?

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Outstanding Contributor.. Allan_D_SIS Outstanding Contributor..
Outstanding Contributor..

Re: Sitescope failing to send <mainParameters> to remote script

Jump to solution

Ok, now got it, in this case please try to change the following master.config line (master.config is located under SiteScope\groups folder):

Currenly:

_scriptRunThroughPerfex=true

 Change it to :

_scriptRunThroughPerfex=false

Regards,

 

Allan Delgado Calderon
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
4 Replies
Outstanding Contributor.. Allan_D_SIS Outstanding Contributor..
Outstanding Contributor..

Re: Sitescope failing to send <mainParameters> to remote script

Jump to solution

Hello

Please run the script using the command line (cmd) and check how much time is taking to run and based on that you must adjust the timeout.

Let us know how it goes.

Regards,

Allan Delgado Calderon
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
djsubit Absent Member.
Absent Member.

Re: Sitescope failing to send <mainParameters> to remote script

Jump to solution

Thanks for the response. But how can I run a remote script, from Sitescope, and pass through the parameters? Keep in mind the script executes just fine until I add in the <mainParameters> value.

0 Likes
Outstanding Contributor.. Allan_D_SIS Outstanding Contributor..
Outstanding Contributor..

Re: Sitescope failing to send <mainParameters> to remote script

Jump to solution

Ok, now got it, in this case please try to change the following master.config line (master.config is located under SiteScope\groups folder):

Currenly:

_scriptRunThroughPerfex=true

 Change it to :

_scriptRunThroughPerfex=false

Regards,

 

Allan Delgado Calderon
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation.
0 Likes
djsubit Absent Member.
Absent Member.

Re: Sitescope failing to send <mainParameters> to remote script

Jump to solution

Accidentally clicked on "Accept as solution." Changed perfex setting, restarted Sitescope but still get the same timeout error.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.