Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE
Acclaimed Contributor.. KAKA_2 Acclaimed Contributor..
Acclaimed Contributor..
403 views

remote scripts not loaded on SiteScope Server

Jump to solution

Hello Support,

I am configuring an script monitor and in order to do it, i have created a script under the $HOME/scripts for the user which will be used to connect to this server from sitescope server.

on sitescope i selected the script monitor and then selected the remote server but under the script i don't see script. i have tried reload scripts but that does not help. (tested connection to sever which is successful)

What else i am supposed to configure?

Any help will be appreciated.

-KAKA-

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

Re: remote scripts not loaded on SiteScope Server

Jump to solution

So this looks not the firewall issue. Instead we see multiple "No such file or directory" errors around required commands, which could be different per Operating system: selection.

e.g.
/usr/sbin/swapinfo: No such file or directory
/usr/bin/ps: No such file or directory

You may want to find out why your remote shell account cannot run these commands in your environment?

Regards,

6 Replies
Absent Member.. Mauricio_M_SIS Absent Member..
Absent Member..

Re: remote scripts not loaded on SiteScope Server

Jump to solution

Hello,

Please try to upload the script to the SiteScope/scripts.remote folder instead.

Best Regards

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: remote scripts not loaded on SiteScope Server

Jump to solution
0 Likes
Acclaimed Contributor.. KAKA_2 Acclaimed Contributor..
Acclaimed Contributor..

Re: remote scripts not loaded on SiteScope Server

Jump to solution

hello nyanko,

Thank you for your response. i had already set the correct permissions using chmod +x and there are no symbolic link. Could it be a firewall issue? if yes, what port i should check? i already checked the port 22 and there is no problem with it.

PS: also tried chmod 777 but no use.

-KAKA-

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: remote scripts not loaded on SiteScope Server

Jump to solution

Please review [UNIX Remote Servers] settings. If [Test] / [Detailed Test] to your SSH target is successful, that should mean TCP 22 connection to your SSH server is OK.

Regards,



Acclaimed Contributor.. KAKA_2 Acclaimed Contributor..
Acclaimed Contributor..

Re: remote scripts not loaded on SiteScope Server

Jump to solution

test connection is ok. also i am able to telnet on port 22 + firewall logs shows nothing blocked for 22. below is the detail for detailed test.

Connection Successful, attempting monitor tests...
Testing connection to : TroubledHost

Attempting SSH V1 connect.

 

Testing CPU Monitor

line 01: -bash: /usr/sbin/sar: No such file or directory

---------- result ----------
category: good
status: no data
utilization: n/a
utilization cpu # 1: 0%
CPU Monitor Test complete.

Testing Disk Space Monitor

Reading list of disks to find a disk to monitor


line 01: -bash: /usr/bin/df: No such file or directory

Testing Memory Monitor

line 01: -bash: /usr/sbin/swapinfo: No such file or directory

---------- result ----------
category: good
status: no data
percent used: n/a
MB free: n/a
pages/sec: n/a
virtual memory or swap space used %: n/a
virtual memory or swap space MB free: n/a
physical memory used %: n/a
physical memory MB free: n/a

Checking memory again (to get page faults)

line 01: -bash: /usr/sbin/swapinfo: No such file or directory

---------- result ----------
category: good
status: no data
percent used: n/a
MB free: n/a
pages/sec: n/a
virtual memory or swap space used %: n/a
virtual memory or swap space MB free: n/a
physical memory used %: n/a
physical memory MB free: n/a
Memory Monitor Test complete.

Testing Service Monitor

Reading list of processes to find a process to monitor

Finding column names...
Column "name" read from column 0 to -1

line 01: -bash: /usr/bin/ps: No such file or directory

 

All Tests Complete

-KAKA-

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: remote scripts not loaded on SiteScope Server

Jump to solution

So this looks not the firewall issue. Instead we see multiple "No such file or directory" errors around required commands, which could be different per Operating system: selection.

e.g.
/usr/sbin/swapinfo: No such file or directory
/usr/bin/ps: No such file or directory

You may want to find out why your remote shell account cannot run these commands in your environment?

Regards,

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.