Absent Member.
Absent Member.

Unable to Start Agent on OES 2018 Server


I am running Storage Manager for eDirectory, running on OES 2018 (fully patched). Storage manager is installed from the 18 July release. I have two servers, storage-mgr where I am running the engine, and agent, and an event monitor, and files which is my main file server with NSS volumes and it has a second event monitor and a second agent.

Everything on the storage-mgr server is running OK.

However, on files I cannot get the agent to run - the event monitor however is OK. There are no messages in /var/log/messages, and nothing in /var/opt/novell/storagemanager/agent. When I try to start the service from nsmagent-config, I just see "Unknown Status". If I run Display Status I see:

Checking for service Novell Storage Manager Agent ..unused
● nsmagentd.service - LSB: Novell Storage Manager Agent
Loaded: loaded (/etc/init.d/nsmagentd; bad; vendor preset: disabled)
Active: active (exited) since Thu 2018-11-15 16:01:28 AEDT; 1h 12min ago
Docs: man:systemd-sysv-generator(8)
Process: 31195 ExecStop=/etc/init.d/nsmagentd stop (code=exited, status=0/SUCCESS)
Process: 31213 ExecStart=/etc/init.d/nsmagentd start (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 512)

If I look in YaST / System / Service Manager and check the detail of nsmagentd, I see

Nov 15 16:01:29 files [31226]: CChannel::connectSocket- Connection creation failed, error = 2
Nov 15 16:01:29 files [31226]: CChannel::init- Connection creation failed, error = 2
Nov 15 16:01:29 files [31226]: CChannel::init- Connection creation failed, error = 2

There are no firewalls running on either server. I've tried de-authorising and re-authorising the agent through the Storage Manager interface, and have also deleted the agent in the interface.

Any advice gratefully accepted!

1 Reply
Absent Member.
Absent Member.


It appears that in the past few days you have not received a response to your
posting. That concerns us, and has triggered this automated reply.

These forums are peer-to-peer, best effort, volunteer run and that if your issue
is urgent or not getting a response, you might try one of the following options:

- Visit https://www.microfocus.com/support-and-services and search the knowledgebase and/or check
all the other self support options and support programs available.
- Open a service request: https://www.microfocus.com/support
- You could also try posting your message again. Make sure it is posted in the
correct newsgroup. (http://forums.microfocus.com)
- You might consider hiring a local partner to assist you.

Be sure to read the forum FAQ about what to expect in the way of responses:

Sometimes this automatic posting will alert someone that can respond.

If this is a reply to a duplicate posting or otherwise posted in error, please
ignore and accept our apologies and rest assured we will issue a stern reprimand
to our posting bot.

Good luck!

Your Micro Focus Forums Team

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.