Micro Focus Frequent Contributor
Micro Focus Frequent Contributor
266 views

Unable to add repository in the git agent

​Hello Team,

I am unable to add a git repository in the Git Agent. The repository is public but I am unable to clone it. The SRL Git agent is throwing the below error:

Git Agent Error.PNG

"Failed to retrieve branch information from specified repository.

fatal: unable to access 

"https://github.com/abhilashhm/git-integration-public.git/":
error:14094419:SSL routines:ssl3_read_bytes:tlsv1 alert access denied"

I tried passing the git URL with and without creds but I get the same error. Please suggest.

 

I also tried the same using GitHub desktop. I have 2 GitHub accounts, one is enterprize which I am able to clone using GitHub desktop and I've another personal account which is throwing me the below error when I try to clone a repository:

GitHub Desktop Error.PNG

"Closing into '<path>'....

fatal:unable to access 'https://github.com/abhilashhm/git-integration-public.git/': schannel: next InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE (0x80090326) - This error usually occurs when a fatal SSL/TLS alert is received (e.g. handshake failed). More details may be available in the Windows System event log."

1 Reply
Micro Focus Expert
Micro Focus Expert

Re: Unable to add repository in the git agent

Hi Abhilash,

 

Are you using a proxy network?

Can you please check the proxy setting and make sure proxy configure correctly in GIT agent UI. 

Thanks,

Naren

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.