Andrew Ardener Absent Member.
Absent Member.
2187 views

An error occurred in the processing of the policy xxx

hi again,

I have an issue where every 2/3 minutes i get a message stating that "An error occurred in the processing of the policy ...." this occurs on a random policy that monitors a service/process on random nodes. The error is changed to a normal state almost straight after.

Example error:

The following message is a Duplicate.
Node: xxxxxxxxxxxx
Message group:OpC
Application: HP OpenView Operations
Object: opcmona (Monitor Agent)
Severity: Warning
Message text: An error occurred in the processing of the policy 'Data Director Process Monitor'. Please check the following errors and take corrective actions. (OpC30-797)
Error during evaluation of rule "ProcessIndex=0", threshold level "ProcessIndex=0" (OpC30-729)
Execution of instance filter script failed. (OpC30-714)
Perl Script execution failed: DynaLoader.pm did not return a true value at \Program Files\HP OpenView\Installed Packages\{790C06B4-844E-11D2-972B-080009EF8C2A}\lib\perl/opcperl.pm line 8.
Compilation failed in require at PerlWrapper line 3.
BEGIN failed--compilation aborted (in cleanup) DynaLoader.pm did not return a true value at \Program Files\HP OpenView\Installed Packages\{790C06B4-844E-11D2-972B-080009EF8C2A}\lib\perl/opcperl.pm line 8.
Compilation failed in require at PerlWrapper line 3.
BEGIN failed--compilation aborted at PerlWrapper line 3.
. (OpC30-750)

Example error now normal:

The following message is a Duplicate.
Node: xxxxxxxxxxxxxx
Message group:OpC
Application: HP OpenView Operations
Object: opcmona (Monitor Agent)
Severity: Normal
Message text: The policy Data Director Process Monitor is now running correctly. (OpC30-798)

Does anyone know what this is? and what i can do about it, as it is hiding real alerts between all its spam.

Thanks,

Andrew
0 Likes
6 Replies
Geert Blommen Honored Contributor.
Honored Contributor.

Re: An error occurred in the processing of the policy xxx

I suspect this is a timing issue, opcmona doesn't receive the value in its timeframe.
The next time opcmona receives a proper value everything returns to normal. Most of the times these messages can be ignored. If you push a nodeinfo policy with OPC_MSG_FLT TRUE you can intercept these messages with a opcmsg policy to auto-acknowledge.
0 Likes
pipol Absent Member.
Absent Member.

Re: An error occurred in the processing of the policy xxx

Hi,

I suspect something goes wrong with your agent installation. It seems that your policy can't load some perl libraries.

Have you got this error on all nodes ?

Check %OvAgentDir%\log\OpC\opcerror for more information.

Regards
Imagination is more important than knowledge.
0 Likes
ZachH Absent Member.
Absent Member.

Re: An error occurred in the processing of the policy xxx

I have a sneaking suspicion that this issue might be related to an issue that we were having with one of our Win2k3 servers.

For us, the issue was perfmon.exe was not working correctly on the server.

If you goto the following reg key on the offending machine, you might see the issue we were having

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Perflib\009

In this folder there should be 2 keys, Counter and Help.

In our situation, the data for these two keys became corrupted somehow. You will know that the data is corrupt if you see nothing in the Data field. If you open the key and scroll all the way down to the bottom of the Value:Data field, you might see some data there.

If your key looks like that, then you have the same issue. To fix, simply copy the data from a known good working machine. If it working correctly, you will see something like this in the data field "1 1847 2 System 4 Memory 6 % Processor Time ..."

HTH
Zach
0 Likes
sudha62001 Absent Member.
Absent Member.

Re: An error occurred in the processing of the policy xxx

Hi There, 

 

I tried the suggested steps, but no luck. Could you please let me know if any one has the answer for this. 

 

Regards, 

 

Sudha. 

0 Likes
Acclaimed Contributor.. KAKA_2 Acclaimed Contributor..
Acclaimed Contributor..

Re: An error occurred in the processing of the policy xxx

Hello Sudha,

 

It really depends on policy to policy. Processing of policy can fail with the different reasons. better you share the problem in a new post.

 

-KAKA-

0 Likes
Highlighted
js_crc Super Contributor.
Super Contributor.

Re: An error occurred in the processing of the policy xxx


Hello,

 

As KAKA_2 explained there are a lot factors that can cause a policy to fail. What source type are you using to gather the values that opcmona will compare against? What is the value of the polling interval of this policy? What agent version are you running to check if there are any known issues that may be fixed in the latest release?

 

Since this issue happens in less than 5 minutes, both error message and normal message, I would go with a trace to the opcmona process in the local agent. I would also check related entries in the system.txt of the node to get more clues on the root source. Is this happening for this rule only or for other ones in the policy too?

 

Hope this helps,

Tags (3)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.